summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--logo-symbol-dark.svg10
-rw-r--r--logo-symbol-light.svg15
-rw-r--r--simplex-chat.desktop11
5 files changed, 69 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e99ae7ac011..410e28e3a249 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = simplex-chat-bin
pkgdesc = A 100% private-by-design chat platform (pre-compiled)
pkgver = 4.5.3
- pkgrel = 1
+ pkgrel = 2
url = https://simplex.chat/
arch = x86_64
license = AGPL3
depends = gmp
+ depends = hicolor-icon-theme
depends = openssl-1.1
depends = zlib
provides = simplex-chat
@@ -17,6 +18,9 @@ pkgbase = simplex-chat-bin
source = https://raw.githubusercontent.com/simplex-chat/simplex-chat/master/docs/SIMPLEX.md
source = https://raw.githubusercontent.com/simplex-chat/simplex-chat/master/docs/SQL.md
source = https://raw.githubusercontent.com/simplex-chat/simplex-chat/master/scripts/message_views.sql
+ source = logo-symbol-dark.svg
+ source = logo-symbol-light.svg
+ source = simplex-chat.desktop
sha256sums = 2bdf32935cc6d5228eb5e930fc07e32fd87e2894988f0a1d8e61dd1070f8cdec
sha256sums = SKIP
sha256sums = SKIP
@@ -24,6 +28,9 @@ pkgbase = simplex-chat-bin
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha512sums = a4249198730398dfee7eae880cf4c6cb4d741cf45c3ca2129396ba466a7b146cf985e06820241ccbac698e1c6cbf09ba1e24d22ba1b4a15a689e9e427da3aaf8
sha512sums = SKIP
sha512sums = SKIP
@@ -31,6 +38,9 @@ pkgbase = simplex-chat-bin
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
b2sums = 4d1fabf40d84c1926ecab132ef9b040d5767bab20ed21e68d85637d8444884d94b83880140ca8fa8ea5b3708f2c074c0f0fc00217db18b807aaedb1d90386e6c
b2sums = SKIP
b2sums = SKIP
@@ -38,5 +48,8 @@ pkgbase = simplex-chat-bin
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = simplex-chat-bin
diff --git a/PKGBUILD b/PKGBUILD
index 32916731b712..0faa36fe339b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='simplex-chat-bin'
_pkgname="${pkgname%%-bin}"
pkgver=4.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='A 100% private-by-design chat platform (pre-compiled)'
arch=('x86_64')
_platform='ubuntu-20_04-x86-64'
@@ -18,35 +18,50 @@ source=(
"$_rawurl/docs/SIMPLEX.md"
"$_rawurl/docs/SQL.md"
"$_rawurl/scripts/message_views.sql"
+ 'logo-symbol-dark.svg'
+ 'logo-symbol-light.svg'
+ 'simplex-chat.desktop'
)
license=('AGPL3')
depends=(
'gmp'
+ 'hicolor-icon-theme'
'openssl-1.1'
'zlib'
)
provides=('simplex-chat')
conflicts=('simplex-chat')
+build() {
+ case "${SIMPLEX_ICON:-light}" in
+ light ) _shade='light' ;;
+ dark ) _shade='dark' ;;
+ * ) _shade='light' ;;
+ esac
+
+ cp "logo-symbol-$_shade.svg" "$_pkgname.svg"
+}
+
package() {
cd "$srcdir" || exit 1
install -Dm0755 "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
install -Dm0644 message_views.sql "$pkgdir/usr/share/doc/$_pkgname/message_views.sql"
install -m0644 {PRIVACY,README,CLI,SIMPLEX,SQL}.md "$pkgdir/usr/share/doc/$_pkgname/"
+ install -Dm0644 "$_pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg"
}
sha256sums=(
'2bdf32935cc6d5228eb5e930fc07e32fd87e2894988f0a1d8e61dd1070f8cdec'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
)
sha512sums=(
'a4249198730398dfee7eae880cf4c6cb4d741cf45c3ca2129396ba466a7b146cf985e06820241ccbac698e1c6cbf09ba1e24d22ba1b4a15a689e9e427da3aaf8'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
)
b2sums=(
'4d1fabf40d84c1926ecab132ef9b040d5767bab20ed21e68d85637d8444884d94b83880140ca8fa8ea5b3708f2c074c0f0fc00217db18b807aaedb1d90386e6c'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
)
# eof
diff --git a/logo-symbol-dark.svg b/logo-symbol-dark.svg
new file mode 100644
index 000000000000..fa598acf3d02
--- /dev/null
+++ b/logo-symbol-dark.svg
@@ -0,0 +1,10 @@
+<svg width="34" height="35" viewBox="0 0 34 35" fill="none" xmlns="http://www.w3.org/2000/svg">
+<path fill-rule="evenodd" clip-rule="evenodd" d="M3.02958 8.60922L8.622 14.2013L14.3705 8.45375L17.1669 11.2498L11.4183 16.9972L17.0114 22.5895L14.1373 25.4633L8.54422 19.871L2.79636 25.6187L0 22.8227L5.74794 17.075L0.155484 11.483L3.02958 8.60922Z" fill="white"/>
+<path fill-rule="evenodd" clip-rule="evenodd" d="M14.0923 25.5156L16.944 22.6642L16.9429 22.6634L22.6467 16.9612L17.0513 11.3675L17.0523 11.367L14.2548 8.56979L8.65972 2.97535L11.5114 0.123963L17.1061 5.71849L22.8099 0.015625L25.6074 2.81285L19.9035 8.51562L25.4984 14.1099L31.2025 8.40729L34 11.2045L28.2958 16.907L33.8917 22.5017L31.0399 25.3531L25.4442 19.7584L19.7409 25.4611L25.3365 31.0559L22.4848 33.9073L16.8892 28.3124L11.1864 34.0156L8.38885 31.2184L14.0923 25.5156Z" fill="url(#paint0_linear_656_10815)"/>
+<defs>
+<linearGradient id="paint0_linear_656_10815" x1="12.8381" y1="-0.678252" x2="9.54355" y2="31.4493" gradientUnits="userSpaceOnUse">
+<stop stop-color="#01F1FF"/>
+<stop offset="1" stop-color="#0197FF"/>
+</linearGradient>
+</defs>
+</svg>
diff --git a/logo-symbol-light.svg b/logo-symbol-light.svg
new file mode 100644
index 000000000000..d8b5951a0bbe
--- /dev/null
+++ b/logo-symbol-light.svg
@@ -0,0 +1,15 @@
+<svg width="34" height="34" viewBox="0 0 34 34" fill="none" xmlns="http://www.w3.org/2000/svg">
+<g clip-path="url(#clip0_14_10)">
+<path fill-rule="evenodd" clip-rule="evenodd" d="M3.02972 8.59396L8.62219 14.186L14.3703 8.43848L17.1668 11.2346L11.4182 16.982L17.0112 22.5742L14.1371 25.448L8.5441 19.8557L2.79651 25.6035L0 22.8074L5.74813 17.0597L0.155656 11.4678L3.02972 8.59396Z" fill="#023789"/>
+<path fill-rule="evenodd" clip-rule="evenodd" d="M14.0922 25.5L16.9434 22.6486L16.9423 22.6478L22.6464 16.9456L17.0512 11.3519L17.0518 11.3514L14.2542 8.55418L8.65961 2.95973L11.5114 0.108337L17.106 5.70288L22.8095 0L25.607 2.79722L19.903 8.5L25.4981 14.0943L31.2022 8.39169L33.9997 11.1889L28.2957 16.8914L33.8914 22.4861L31.0396 25.3375L25.4439 19.7428L19.7404 25.4454L25.3361 31.0403L22.4843 33.8917L16.8887 28.2968L11.1862 34L8.38867 31.2028L14.0922 25.5Z" fill="url(#paint0_linear_14_10)"/>
+</g>
+<defs>
+<linearGradient id="paint0_linear_14_10" x1="12.8379" y1="-0.693875" x2="9.54344" y2="31.4337" gradientUnits="userSpaceOnUse">
+<stop stop-color="#01F1FF"/>
+<stop offset="1" stop-color="#0197FF"/>
+</linearGradient>
+<clipPath id="clip0_14_10">
+<rect width="34" height="34" fill="white"/>
+</clipPath>
+</defs>
+</svg>
diff --git a/simplex-chat.desktop b/simplex-chat.desktop
new file mode 100644
index 000000000000..47730ffad5a0
--- /dev/null
+++ b/simplex-chat.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Categories=Chat;ConsoleOnly;InstantMessaging;Network;
+Comment=Messaging platform without user profile identifiers of any kind — 100% private by design
+Exec=simplex-chat
+GenericName=Secure chat client
+Icon=simplex-chat
+Keywords=chat;console;messaging;privacy;terminal;tty;
+Name=SimpleX
+Terminal=true
+Type=Application
+Version=1.0