summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--simsu.install11
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..596ac6cfeae3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = simsu
+ pkgdesc = A basic Sudoku game
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://gottcode.org/simsu/
+ install = simsu.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ source = http://gottcode.org/simsu/simsu-1.3.1-src.tar.bz2
+ sha256sums = 94cd1728a3bd1743b65c2636cb7ecb739ba7b1b31660fca4b5318908f000e9b7
+
+pkgname = simsu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..affb14748321
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Graeme Gott <graeme@gottcode.org>
+
+pkgname=simsu
+pkgver=1.3.1
+pkgrel=1
+pkgdesc='A basic Sudoku game'
+arch=('i686' 'x86_64')
+url="http://gottcode.org/$pkgname/"
+license=('GPL3')
+depends=('qt5-base')
+install="$pkgname.install"
+source=("http://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
+sha256sums=('94cd1728a3bd1743b65c2636cb7ecb739ba7b1b31660fca4b5318908f000e9b7')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir/" install
+}
diff --git a/simsu.install b/simsu.install
new file mode 100644
index 000000000000..1c0de2e4fa61
--- /dev/null
+++ b/simsu.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}