summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17002e8f23a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Jun 1 08:54:49 UTC 2018
+pkgbase = singlepage-git
+ pkgdesc = Bundle external assets in a HTML file to distribute a stand-alone HTML document.
+ pkgver = r13.0ee88de
+ pkgrel = 1
+ url = https://github.com/Carpetsmoker/singlepage
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go
+
+pkgname = singlepage-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efa5445e4df7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=singlepage-git
+pkgver=r13.0ee88de
+pkgrel=1
+epoch=
+pkgdesc="Bundle external assets in a HTML file to distribute a stand-alone HTML document. "
+arch=('i686' 'x86_64')
+url="https://github.com/Carpetsmoker/singlepage"
+license=('MIT')
+categories=()
+groups=()
+depends=()
+makedepends=('git' 'go')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+noextract=()
+_gourl=arp242.net/singlepage
+
+pkgver() {
+ GOPATH="$srcdir" go get -d ${_gourl}
+ cd "$srcdir/src/${_gourl}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ GOPATH="$srcdir" go get -fix -v ${_gourl}
+}
+
+check() {
+ GOPATH="$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 bin/singlepage "$pkgdir/usr/bin/singlepage"
+ install -Dm644 src/${_gourl}/README.markdown $pkgdir/usr/share/doc/${pkgname%-*}/README.markdown
+ install -Dm644 src/${_gourl}/LICENSE $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}
+