summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90ee1f779ff1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Jul 1 07:52:49 UTC 2020
+pkgbase = sjcam-git
+ pkgdesc = A python CLI tool for controlling SJCAM WiFi Sports Cameras
+ pkgver = r23.b96760b
+ pkgrel = 1
+ url = https://github.com/AdamLaurie/sjcam
+ arch = x86_64
+ arch = i386
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ provides = sjcam-git
+ conflicts = sjcam
+ replaces = sjcam
+ source = sjcam-git::git+https://github.com/AdamLaurie/sjcam
+ md5sums = SKIP
+
+pkgname = sjcam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d79d71e8a37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Alberto Fanjul <albertofanjul@gmail.com>
+pkgname=sjcam-git
+pkgver=r23.b96760b
+pkgrel=1
+pkgdesc="A python CLI tool for controlling SJCAM WiFi Sports Cameras"
+arch=(x86_64 i386)
+url="https://github.com/AdamLaurie/sjcam"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(git python-setuptools)
+provides=(sjcam-git)
+conflicts=(sjcam)
+replaces=(sjcam)
+backup=()
+options=()
+install=
+source=("$pkgname::git+https://github.com/AdamLaurie/sjcam")
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+
+ # Git, tags available
+ #printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}