summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e342e15b262..3e9c075b81a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = skanlite-git
pkgdesc = Image Scanning Application
- pkgver = 23.08.3.r6.g9b3851b
+ pkgver = 24.02.1.r9.g5e21882
pkgrel = 1
url = https://invent.kde.org/graphics/skanlite
arch = x86_64
- license = GPL
+ license = GPL-3.0-only
makedepends = extra-cmake-modules
makedepends = git
- makedepends = kdoctools5
- depends = kio5
+ makedepends = kdoctools
+ depends = kio
+ depends = ksanecore
+ depends = kxmlgui
depends = libksane
provides = skanlite
conflicts = skanlite
diff --git a/PKGBUILD b/PKGBUILD
index b9f7117283b1..98b73b35297f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,23 @@
_pkgname="skanlite"
pkgname="$_pkgname-git"
-pkgver=23.08.3.r6.g9b3851b
+pkgver=24.02.1.r9.g5e21882
pkgrel=1
pkgdesc='Image Scanning Application'
url='https://invent.kde.org/graphics/skanlite'
-license=(GPL)
-arch=(x86_64)
+license=('GPL-3.0-only')
+arch=('x86_64')
depends=(
- 'kio5'
+ 'kio'
+ 'ksanecore'
+ 'kxmlgui'
'libksane'
)
makedepends=(
'extra-cmake-modules'
'git'
- 'kdoctools5'
+ 'kdoctools'
)
provides+=("$_pkgname")
@@ -45,37 +47,33 @@ pkgver() {
| sed 's@\ .*$@@'
)
local _revision=$(
- git rev-list --count $_commit..HEAD
+ git rev-list --count --cherry-pick "$_commit"...HEAD
)
local _hash=$(
- git rev-parse --short HEAD
+ git rev-parse --short=7 HEAD
)
printf '%s.r%s.g%s' \
"$_version" \
"$_revision" \
"$_hash"
-}
-
-prepare() {
- local _pkgver=$(pkgver)
- _pkgver="${_pkgver%%.r*}"
- local _ver_maj=$(sed -E 's@^([0-9]+)\.([0-9]+)\.([0-9]+)$@\1@' <<< "$_pkgver")
- local _ver_min=$(sed -E 's@^([0-9]+)\.([0-9]+)\.([0-9]+)$@\2@' <<< "$_pkgver")
- local _ver_pat=$(sed -E 's@^([0-9]+)\.([0-9]+)\.([0-9]+)$@\3@' <<< "$_pkgver")
+ local _ver_maj=$(sed -E 's@^([0-9]+)\.([0-9]+)\.([0-9]+)$@\1@' <<< "$_version")
+ local _ver_min=$(sed -E 's@^([0-9]+)\.([0-9]+)\.([0-9]+)$@\2@' <<< "$_version")
+ local _ver_pat=$(sed -E 's@^([0-9]+)\.([0-9]+)\.([0-9]+)$@\3@' <<< "$_version")
sed -E \
-e 's@^(\s*set\s*\(RELEASE_SERVICE_VERSION_MAJOR) .*$@\1 "'"$_ver_maj"'")@' \
-e 's@^(\s*set\s*\(RELEASE_SERVICE_VERSION_MINOR) .*$@\1 "'"$_ver_min"'")@' \
-e 's@^(\s*set\s*\(RELEASE_SERVICE_VERSION_MICRO) .*$@\1 "'"$_ver_pat"'")@' \
- -i "$_pkgsrc/CMakeLists.txt"
+ -i CMakeLists.txt
}
build() {
local _cmake_options=(
-B build
-S "$_pkgsrc"
+ -DQT_MAJOR_VERSION=6
-DBUILD_TESTING=OFF
-Wno-dev
)
@@ -85,5 +83,5 @@ build() {
}
package() {
- DESTDIR="${pkgdir:?}" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}