summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
-rw-r--r--makevars.diff19
3 files changed, 43 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d0cd182c559..e89d272651f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 7 11:15:05 UTC 2017
+# Mon Apr 30 19:00:40 UTC 2018
pkgbase = skribilo-git
pkgdesc = The Ultimate Document Programming Framework from git
- pkgver = v0.9.3_9_gc3d1019r987
- pkgrel = 2
+ pkgver = 0.9.4r1010
+ pkgrel = 1
url = http://www.nongnu.org/skribilo/
arch = any
license = GPL
@@ -15,7 +15,9 @@ pkgbase = skribilo-git
conflicts = skribilo
options = !makeflags
source = git://git.sv.gnu.org/skribilo.git
+ source = makevars.diff
md5sums = SKIP
+ md5sums = fdefd9d3a084f4d48f57df699fb7cdf0
pkgname = skribilo-git
diff --git a/PKGBUILD b/PKGBUILD
index 462890b05fe1..614170b7f904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=skribilo-git
-pkgver=v0.9.3_9_gc3d1019r987
-pkgrel=2
+pkgver=0.9.4r1010
+pkgrel=1
pkgdesc="The Ultimate Document Programming Framework from git"
arch=('any')
url="http://www.nongnu.org/skribilo/"
@@ -10,18 +10,29 @@ depends=('bash')
makedepends=('git' 'guile-reader' 'ploticus')
provides=('skribilo')
conflicts=('skribilo')
-source=("git://git.sv.gnu.org/skribilo.git")
-md5sums=('SKIP')
+source=("git://git.sv.gnu.org/skribilo.git" makevars.diff)
+md5sums=('SKIP'
+ 'fdefd9d3a084f4d48f57df699fb7cdf0')
options=("!makeflags")
pkgver() {
cd "${pkgname%-git}"
- printf "%sr%s" $(git describe --tags|tr - _) $(git rev-list --count HEAD)
+ printf "%sr%s" $(git describe --tags|tr - _|cut -c2-) $(git rev-list --count HEAD)
+}
+
+prepare() {
+ cd "${pkgname%-git}"/po
+ patch -Np0 < "$srcdir"/makevars.diff
+ cd ..
+# gettextize -f
+ libtoolize -c -f
+ aclocal -I m4
+ automake --add-missing
+ autoconf
}
build() {
cd "${pkgname%-git}"
- autoconf
GUILE_EFFECTIVE_VERSION=2.0 GUILE=/usr/bin/guile2.0 ./configure --prefix=/usr
make
}
@@ -30,6 +41,6 @@ package() {
cd "${pkgname%-git}"
make DESTDIR="$pkgdir/" install
rm $pkgdir/usr/share/info/*.png
- install -d $pkgdir/usr/share/doc/$pkgname
- find $srcdir/ -name "*.png" -exec install -m644 {} $pkgdir/usr/share/doc/$pkgname \;
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ find $srcdir/ -name "*.png" -exec install -m644 {} "$pkgdir"/usr/share/doc/$pkgname \;
}
diff --git a/makevars.diff b/makevars.diff
new file mode 100644
index 000000000000..8eec62ed5fc7
--- /dev/null
+++ b/makevars.diff
@@ -0,0 +1,19 @@
+--- Makevars 2018-04-29 23:06:53.982006780 +0200
++++ Makevars.new 2018-04-30 20:20:31.546428746 +0200
+@@ -42,9 +42,14 @@
+ # This is the list of locale categories, beyond LC_MESSAGES, for which the
+ # message catalogs shall be used. It is usually empty.
+ EXTRA_LOCALE_CATEGORIES =
+-
++PACKAGE_GNU =
+ # Local Variables:
+ # coding: utf-8
+ # End:
+
+ # arch-tag: 2111079c-04fd-4ea1-b078-f857135897ad
++DIST_DEPENDS_ON_UPDATE_PO = yes
++MSGINIT_OPTIONS =
++MSGMERGE_OPTIONS =
++USE_MSGCTXT = no
++PACKAGE_GNU =
+\ Kein Zeilenumbruch am Dateiende.