summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD16
-rw-r--r--sks.install11
2 files changed, 21 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91e61d0147de..e5bf4ef8d37f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ md5sums=('43f0cc8b4b43d798d453fedad840f926'
'9cf5495b95e84ed91788c04c9ce1b8c1'
'e8c7dcbb7db3ad879d391a7c0127a068'
'f28a2d0b151996a99bb006b8e1d29408')
-validpgpkeys=(65F173BEC0450DA07A58619716E0CF8D6B0B9508) # Kristian Fiskerstrand
+validpgpkeys=(C90EF1430B3AC0DFD00E6EA541259773973A612A) # SKS Keyserver Signing Key
prepare() {
@@ -32,6 +32,15 @@ prepare() {
patch -Np1 -i "$srcdir/500_debian_fhs.patch"
cp Makefile.local.unused Makefile.local
+
+ # XXX Due to how ocaml package is generated in arch, we cannot link
+ # dynamically, so we workarround the problem using runtime-variant _pic
+ # More info:
+ # - https://wiki.ubuntu.com/SteveBeattie/PIENotes#Incompatible_relocation_R_X86_64_32
+ # - https://bugs.archlinux.org/task/42748
+ # - http://caml.inria.fr/mantis/view.php?id=6693
+ echo "OCAMLOPT=ocamlopt -runtime-variant _pic" >> Makefile.local
+
sed -i -e 's#LIBDB=-ldb-4.6#LIBDB=-ldb-5.3#g' Makefile.local
sed -i -e "s#/usr/local#$pkgdir/usr#g" Makefile.local
sed -i -e "s#/usr/share/man#$pkgdir/usr/share/man#g" Makefile.local
@@ -39,10 +48,11 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
-
unset MAKEFLAGS
make dep
- make CFLAGS="$CFLAGS -I`ocamlc -where` -I ." all
+
+ # XXX Parallel compiling not supporting for Bdb module, force -j1 always.
+ make CFLAGS="$CFLAGS -I`ocamlc -where` -I ." -j1 all
}
package() {
diff --git a/sks.install b/sks.install
index 402f8930e821..671f2ae1dad0 100644
--- a/sks.install
+++ b/sks.install
@@ -20,7 +20,11 @@ post_install() {
mkdir -p /var/spool/sks
chown sks:sks /var/spool/sks
- echo ">> Place 'sks' in DAEMONS= in /etc/rc.conf to enable sks on system boot."
+ echo "NOTE: sks-db could not started without any imported database."
+ echo " Please before to start the sks-db service first import"
+ echo " a database. Read instructions from:"
+ echo
+ echo " https://bitbucket.org/skskeyserver/sks-keyserver/wiki/Peering#!initial-keydump"
}
post_remove() {
@@ -28,8 +32,9 @@ post_remove() {
userdel sks && echo "done."
rm -r /var/run/sks
-
- echo "Not removing tmp and log directories"
+
+ echo "Keeping /var/lib/sks, /var/spool/sks and /var/log/sks"
+ echo "Remove them manually if you want."
}
op=$1