summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xpostinst.sh2
-rwxr-xr-xprerm.sh10
-rw-r--r--[-rwxr-xr-x]skywire-autoconfig0
-rwxr-xr-xupdates.sh2
4 files changed, 13 insertions, 1 deletions
diff --git a/postinst.sh b/postinst.sh
new file mode 100755
index 000000000000..a04775cbb87e
--- /dev/null
+++ b/postinst.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+[[ -f /opt/skywire/scripts/skywire-autoconfig ]] && /opt/skywire/scripts/skywire-autoconfig
diff --git a/prerm.sh b/prerm.sh
new file mode 100755
index 000000000000..7c58455949ff
--- /dev/null
+++ b/prerm.sh
@@ -0,0 +1,10 @@
+#!/bin/bash
+if [[ -d /opt/skywire/local ]]; then
+ rm -rf /opt/skywire/local
+fi
+if [[ -f /opt/skywire/skywire.json ]] ; then
+ rm -rf /opt/skywire/*.json
+fi
+if [[ -f /opt/skywire/users.db ]] ; then
+ rm -rf /opt/skywire/users.db
+fi
diff --git a/skywire-autoconfig b/skywire-autoconfig
index b1ae12137129..b1ae12137129 100755..100644
--- a/skywire-autoconfig
+++ b/skywire-autoconfig
diff --git a/updates.sh b/updates.sh
index 2cf663f4a16f..cafff4debe7d 100755
--- a/updates.sh
+++ b/updates.sh
@@ -30,5 +30,5 @@ makepkg --printsrcinfo > .SRCINFO
sha256sum skywire-scripts.tar.gz
echo "don't forget to increment pkgrel if you edited the PKGBUILD"
echo
-echo "git add -f ${_debPKGBUILD} ${_ccdebPKGBUILD} ${_devPKGBUILD} ${_gitPKGBUILD} PKGBUILD .SRCINFO skywire-autoconfig com.skywire.Skywire.desktop com.skywirevpn.SkywireVPN.desktop skywirevpn.png skywire.png skywire.service skywire-autoconfig.service updates.sh test.sh"
+echo "git add -f ${_debPKGBUILD} ${_ccdebPKGBUILD} ${_devPKGBUILD} ${_gitPKGBUILD} PKGBUILD .SRCINFO skywire-autoconfig com.skywire.Skywire.desktop com.skywirevpn.SkywireVPN.desktop skywirevpn.png skywire.png skywire.service skywire-autoconfig.service postinst.sh prerm.sh updates.sh test.sh"
echo 'git commit -m " "'