summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD14
1 files changed, 1 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9fb6b910156..6a8b1d8ef4af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,10 @@
pkgname="sleek"
pkgver=1.0.0
pkgrel=1
-epoch=1
pkgdesc="Todo app based on the todo.txt format for Linux, free and open-source"
arch=("x86_64")
url="https://github.com/ransome1/sleek/"
license=("MIT")
-provides=("sleek")
options=(!strip)
makedepends=("npm")
depends=("electron")
@@ -22,20 +20,10 @@ build() {
package() {
cd "$srcdir/$pkgname-${pkgver}"
-
npm run pack
-
install -Dm644 "dist/linux-unpacked/resources/app.asar" "$pkgdir/usr/lib/$pkgname.asar"
-
install -d -Dm644 "${pkgdir}/usr/share"
cp -r "dist/linux-unpacked/${pkgname}" "${pkgdir}/usr/share"
-
- printf "[Desktop Entry]\nName=${pkgname}\nComment=${pkgdesc}\nExec=/usr/bin/${pkgname}\nTerminal=false\nType=Application\nIcon=sleek\nCategories=ProjectManagement;" > ${pkgname}.desktop
+ install -Dm755 "${pkgname}.sh" -t "$pkgdir/usr/bin/${pkgname}"
install -Dm644 "${pkgname}.desktop" -t "$pkgdir/usr/share/applications/"
-
- cat << '__EOF__' | install -Dm755 /dev/stdin "${pkgdir}"/usr/bin/sleek
-#!/bin/sh
-
-exec electron /usr/lib/sleek.asar "$@"
-__EOF__
}