summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6bbc4ba865b..75de2735d3e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,25 @@
# Maintainer: Murat Çileli <murat.cileli@gmail.com>
-pkgbase="pkgbase"
pkgname="adwaita-creamy"
-pkgver="0.1"
+pkgver="3.24.8"
pkgrel="1"
-pkgdesc="Refreshed new Adwaita theme with creamy colors and minor changes. "
+pkgdesc="Refreshed new Adwaita theme with creamy colors and minor changes."
arch=("x86_64")
license=("MIT")
url="https://github.com/murat-cileli/adwaita-creamy"
makedepends=()
provides=("adwaita-creamy")
-
-source=("git+https://github.com/murat-cileli/adwaita-creamy.git")
+source=("$pkgname-$pkgver::https://github.com/murat-cileli/adwaita-creamy/archive/$pkgver.tar.gz")
sha256sums=("SKIP")
-
-build() {
- cd "${pkgname}"
- mkdir -p ~/.themes/adwaita-creamy
- cp gtk-2.0 ~/.themes/adwaita-creamy/ -R
- cp gtk-3.0 ~/.themes/adwaita-creamy/ -R
- cp index.theme ~/.themes/adwaita-creamy/
-}
-
+user_name="$(logname)"
+
package() {
- echo "Package"
-}
+ # Remove old version from user's home themes
+ rm -rf $pkgdir/home/${user_name}/.themes/$pkgname
+
+ # Create directory
+ mkdir -p $pkgdir/usr/share/themes/$pkgname
+ # Copy contents
+ cp -r "$srcdir/$pkgname-$pkgver/." "$pkgdir/usr/share/themes/$pkgname"
+}