summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--moduleupdates.patch12
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a691edb875d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sleepyhead
+ pkgdesc = Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment.
+ pkgver = 0.9.8
+ pkgrel = 1
+ url = http://sourceforge.net/projects/sleepyhead
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-serialport
+ depends = qt5-webkit
+ provides = sleepyhead
+ conflicts = sleepyhead-git
+ source = git://git.code.sf.net/p/sleepyhead/code#tag=0.9.8-0
+ source = moduleupdates.patch
+ sha256sums = SKIP
+ sha256sums = af1390195fc4a5f2aa0cced24b1ce1a629dbd608a40d10dc319cfcbd959bec02
+
+pkgname = sleepyhead
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5db9f9dc50e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jason Lenz <Jason@Lenzplace.org>
+pkgname=sleepyhead
+pkgver=0.9.8
+pkgrel=1
+pkgdesc="Open-source, cross platform, sleep tracking software with a focus on monitoring CPAP treatment."
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/sleepyhead"
+license=('GPL')
+depends=(
+ 'qt5-base'
+ 'qt5-serialport'
+ 'qt5-webkit'
+)
+makedepends=('git')
+provides=("$pkgname")
+conflicts=('sleepyhead-git')
+
+source=(
+ "git://git.code.sf.net/p/sleepyhead/code#tag=0.9.8-0"
+ 'moduleupdates.patch'
+)
+
+sha256sums=(
+ 'SKIP'
+ af1390195fc4a5f2aa0cced24b1ce1a629dbd608a40d10dc319cfcbd959bec02
+)
+
+build() {
+ cd code
+ patch -Np1 -i "$srcdir/moduleupdates.patch"
+ ./configure
+ make
+}
+
+package() {
+ install -D "$srcdir/code/sleepyhead/SleepyHead" "$pkgdir/usr/bin/SleepyHead"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/moduleupdates.patch b/moduleupdates.patch
new file mode 100644
index 000000000000..78435431054a
--- /dev/null
+++ b/moduleupdates.patch
@@ -0,0 +1,12 @@
+diff -aur sleepyhead-code/sleepyhead/sleepyhead.pro sleepyhead-code2/sleepyhead/sleepyhead.pro
+--- sleepyhead-code/sleepyhead/sleepyhead.pro 2014-09-27 08:22:20.940889023 -0500
++++ sleepyhead-code2/sleepyhead/sleepyhead.pro 2014-09-27 08:23:12.687558557 -0500
+@@ -7,7 +7,7 @@
+ QT += core gui network xml serialport
+
+ greaterThan(QT_MAJOR_VERSION,4) {
+- QT += widgets webkitwidgets
++ QT += widgets webkitwidgets printsupport
+ } else { # qt4
+ QT += webkit
+ }