summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD37
4 files changed, 40 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 306791f22c3d..a928db2dff8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = slepc
pkgdesc = Scalable library for Eigenvalue problem computations
- pkgver = 3.17.0
+ pkgver = 3.21.0
pkgrel = 1
url = https://slepc.upv.es
install = slepc.install
arch = x86_64
- license = custom
+ license = BSD-2-Clause
makedepends = gcc-fortran
- depends = petsc>=3.17
- source = https://slepc.upv.es/download/distrib/slepc-3.17.0.tar.gz
- md5sums = 8e1514936f581217d0febeac889a2379
+ makedepends = cython
+ depends = petsc>=3.21
+ provides = slepc4py
+ options = staticlibs
+ source = https://slepc.upv.es/download/distrib/slepc-3.21.0.tar.gz
+ md5sums = 649de126f3bccbb8ee85be76225874b2
pkgname = slepc
diff --git a/.gitignore b/.gitignore
index 3f1864bb0ec4..f59ec20aabf5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1 @@
-pkg
-src
-*.tar.gz
-*.tar.xz
+* \ No newline at end of file
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..515cc9cb1964
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[slepc]
+source = "gitlab"
+gitlab = "slepc/slepc"
+use_max_tag = true
+prefix = "v" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 05856ae2bc9a..fc3bcfd46064 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,19 @@
# Contributor: Felix Schindler <aur dot felixschindler dot net>
# Contributor: Lucas H. Gabrielli <heitzmann@gmail.com>
pkgname=slepc
-pkgver=3.17.0
+pkgver=3.21.0
pkgrel=1
pkgdesc="Scalable library for Eigenvalue problem computations"
-arch=('x86_64')
+arch=(x86_64)
url="https://${pkgname}.upv.es"
-license=('custom')
-depends=("petsc>=${pkgver:0:4}")
-makedepends=(gcc-fortran)
-install=slepc.install
+license=(BSD-2-Clause)
+options=(staticlibs)
+depends=("petsc>=${pkgver::4}")
+makedepends=(gcc-fortran cython)
+provides=('slepc4py')
+install=${pkgname}.install
source=(${url}/download/distrib/${pkgname}-${pkgver/_/-}.tar.gz)
-md5sums=('8e1514936f581217d0febeac889a2379')
-
-# export MAKEFLAGS="-j1"
+md5sums=('649de126f3bccbb8ee85be76225874b2')
build() {
# get SLEPC_DIR
@@ -33,8 +33,22 @@ build() {
unset PETSC_ARCH
export SLEPC_DIR=${_build_dir}
- python ./configure --prefix=${pkgdir}${_install_dir} --with-clean
- make
+ CONFOPTS="--with-clean \
+ --with-slepc4py=1"
+
+ echo ${CONFOPTS}
+
+ python ./configure --prefix=${pkgdir}${_install_dir} ${CONFOPTS}
+ make ${MAKEFLAGS} all
+ make DESTDIR=${srcdir}/tmp install
+}
+
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
+ export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ fi
+ PYTHONPATH=${srcdir}/tmp/${_install_dir}/lib:${PYTHONPATH} make check
}
package() {
@@ -74,6 +88,7 @@ package() {
mkdir -p ${pkgdir}/etc/profile.d
echo "export SLEPC_DIR=${_install_dir}" >${pkgdir}/etc/profile.d/slepc.sh
+ echo export PYTHONPATH=${_install_dir}/lib:'${PYTHONPATH}' >>${pkgdir}/etc/profile.d/slepc.sh
chmod +x ${pkgdir}/etc/profile.d/slepc.sh
# show where the shared libraries are