summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD18
-rwxr-xr-xslimjet-browser5
2 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d9cd227dbb7..f22fae237e39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="A lightweight Browser based on Blink (**added: 'slim-root' sandbox-user
arch=('x86_64')
url="http://www.slimjet.com"
depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme' 'xorg-xhost'
- 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'openssl' 'nspr' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
+ 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'openssl' 'nspr' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
optdepends=('kdebase-kdialog: needed for file dialogs in KDE' 'ttf-liberation: fix fonts for some PDFs')
makedepends=('pacman>=4.2.0' 'imagemagick>7.0.0')
options=('!emptydirs' '!strip')
@@ -16,10 +16,12 @@ provides=('slimjet-browser')
replaces=('slimjet')
license=('custom:freeware' 'MIT')
source=("${pkgname}-${pkgver}-${arch}.deb::https://www.${_origname}.com/release/archive/${pkgver}/${_origname}_amd64.deb"
- "LICENSE")
+ "LICENSE"
+ "slimjet-browser")
install='slimjet-browser.install'
sha256sums=('6aaffba334238429f92b5fe29d10c7799ffdb34d1ac94d2fa9e73981d8ac567b'
- 'fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e')
+ 'fc0297ac9ec689eeb610024c9f59d5f47661d5e1fdf18bd3c5e456068c47d15e'
+ '8ab05210886cda05d2d9c0463e093bd1419ad8dde9dc3f4892149d6cda23bee0')
package() {
rm -f 'control.tar.gz' 'debian-binary'
@@ -35,15 +37,7 @@ package() {
sed 's%^Icon=flashpeak-slimjet%Icon=slimjet%g' -i "usr/share/applications/slimjet.desktop"
mv "opt/slimjet" "usr/share/slimjet"
rm -rf "opt"
- printf '#!/bin/sh
-xhost + &>/dev/zero
-su - slim-root -c "#\!/bin/sh
-export FLASHPEAK=/usr/share/slimjet/flashpeak-slimjet
-export DISPLAY=:0
-\${FLASHPEAK} $@
-"'
-" > "usr/bin/slimjet-browser"
- chmod 0755 "usr/bin/slimjet-browser"
+ install -m0755 "${srcdir}/slimjet-browser" "usr/bin/slimjet-browser"
msg2 "Moving sanitized file-tree to package-directory ..."
mv --target-directory="${pkgdir}" usr
chmod -R 0755 "${pkgdir}/"
diff --git a/slimjet-browser b/slimjet-browser
new file mode 100755
index 000000000000..1c16e417256c
--- /dev/null
+++ b/slimjet-browser
@@ -0,0 +1,5 @@
+#!/bin/bash
+ARGV=(${*})
+xhost + &>/dev/zero
+su - slim-root -c \
+"DISPLAY=:0 /usr/share/slimjet/flashpeak-slimjet ${ARGV[*]}" & \ No newline at end of file