summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c5549cb003e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = slock-plus
+ pkgdesc = A simple screen locker for X, with patches: control clear, message, terminalkeys, quickcancel
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://tools.suckless.org/slock
+ arch = x86_64
+ license = MIT
+ depends = libxext
+ depends = libxrandr
+ provides = slock
+ conflicts = slock
+ source = https://git.sr.ht/~craftyguy/slock/archive/1.4-plus.tar.gz
+ sha256sums = 64a94798cb5233ccd9e747b43b08316d38bcf33a542276d016a996343423606d
+
+pkgname = slock-plus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51c27c2fc762
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+
+pkgname=slock-plus
+_pkgname=slock
+pkgver=1.4
+pkgrel=1
+pkgdesc="A simple screen locker for X, with patches: control clear, message, terminalkeys, quickcancel"
+arch=('x86_64')
+url="http://tools.suckless.org/slock"
+license=('MIT')
+depends=('libxext' 'libxrandr')
+provides=('slock')
+conflicts=('slock')
+source=("https://git.sr.ht/~craftyguy/${_pkgname}/archive/${pkgver}-plus.tar.gz")
+sha256sums=('64a94798cb5233ccd9e747b43b08316d38bcf33a542276d016a996343423606d')
+
+prepare() {
+ cd "$srcdir/slock-$pkgver-plus"
+ sed -i 's|static const char \*group = "nogroup";|static const char *group = "nobody";|' config.def.h
+ sed -ri 's/((CPP|C|LD)FLAGS) =/\1 +=/g' config.mk
+}
+
+build() {
+ cd "$srcdir/slock-$pkgver-plus"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd "$srcdir/slock-$pkgver-plus"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}