summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fd7b2788c0b..33b12933fe86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = slurm
pkgdesc = Monitoring traffic statistics in realtime
- pkgver = 0.4.2
+ pkgver = 0.4.3
pkgrel = 1
url = https://github.com/mattthias/slurm/wiki
arch = i686
arch = x86_64
license = GPL
- makedepends = scons
+ makedepends = cmake
depends = ncurses
- source = https://github.com/mattthias/slurm/archive/upstream/0.4.2.tar.gz
- md5sums = b949aca331c25bf5c225faafc1948069
+ source = https://github.com/mattthias/slurm/archive/upstream/0.4.3.tar.gz
+ md5sums = ff39b8e1fd31274ba1bb36d4aadc1d48
pkgname = slurm
diff --git a/PKGBUILD b/PKGBUILD
index 56bb38564667..24e73c5b2689 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Christof Musik <christof@senfdax.de>
# Contributor: Falconindy
pkgname=slurm
-pkgver=0.4.2
+pkgver=0.4.3
pkgrel=1
pkgdesc="Monitoring traffic statistics in realtime"
#url="http://www.wormulon.net/slurm"
@@ -12,28 +12,25 @@ url="https://github.com/mattthias/slurm/wiki"
license=("GPL")
arch=('i686' 'x86_64')
depends=('ncurses')
-makedepends=('scons')
+makedepends=('cmake')
#source=(http://www.wormulon.net/files/code/slurm/$pkgname-$pkgver.tar.gz)
#source=(http://downloads.openwrt.org/sources/$pkgname-$pkgver.tar.gz)
source=(https://github.com/mattthias/$pkgname/archive/upstream/$pkgver.tar.gz)
-md5sums=('b949aca331c25bf5c225faafc1948069')
+md5sums=('ff39b8e1fd31274ba1bb36d4aadc1d48')
build() {
cd "$srcdir/$pkgname-upstream-$pkgver"
#./configure --prefix=/usr CPPFLAGS=-D__Debian__
- #make
- scons
+ #scons
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
}
package() {
- cd "$srcdir/$pkgname-upstream-$pkgver"
- #make DESTDIR="$pkgdir" install
- install -Dm755 slurm "$pkgdir/usr/bin/slurm"
-
- # install themes
- install -dm755 "$pkgdir/usr/share/slurm"
- install -Dm644 -t "$pkgdir/usr/share/slurm" themes/*.theme
-
- install -Dm644 slurm.1 "$pkgdir/usr/share/man/man1/slurm.1"
+ cd "$srcdir/$pkgname-upstream-$pkgver/build"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../slurm.1 "$pkgdir/usr/share/man/man1/slurm.1"
}