summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--slurm-llnl.install5
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae3d6a0b006b..2b6eeabdde47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = slurm-llnl
pkgdesc = Simple Linux Utility for Resource Management
- pkgver = 15.08.9
+ pkgver = 15.08.10
pkgrel = 1
url = http://www.schedmd.com
install = slurm-llnl.install
@@ -32,12 +32,12 @@ pkgbase = slurm-llnl
source = slurmctld.service
source = slurmd.service
source = slurmdbd.service
- source = http://www.schedmd.com/download/total/slurm-15.08.9.tar.bz2
+ source = http://www.schedmd.com/download/total/slurm-15.08.10.tar.bz2
md5sums = 51e4ae2c51edf7c145d1b87bec4c344e
md5sums = cae664b8ef44d01783dade9088e25b53
md5sums = 834b641efbcb45d300630f51f08a9122
md5sums = 231a6634fcf774642021377920fffe39
md5sums = cef9d45137b9bd431dce3cbe85ef9bca
- md5sums = 509229069300075d1caec9756ab5f5bf
+ md5sums = e37126cbf6205ef5369ab542c4436044
pkgname = slurm-llnl
diff --git a/PKGBUILD b/PKGBUILD
index 0434bb6a3aa5..0da98af94099 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Submitter: Fredrik Tegenfeldt <fredrik.tegenfeldt@unige.ch>
pkgname=slurm-llnl
-pkgver=15.08.9
+pkgver=15.08.10
pkgrel=1
pkgdesc="Simple Linux Utility for Resource Management"
arch=('i686' 'x86_64')
@@ -28,7 +28,7 @@ optdepends=("hwloc: enables the task/cgroup plugin"
makedepends=('python')
conflicts=('slurm-llnl-dev' 'slurm-llnl-git')
backup=('etc/default/slurm-llnl')
-install=${pkgname}.install
+install="${pkgname}.install"
source=("slurm-tmpfiles.conf"
"slurm-llnl-default-conf"
"slurmctld.service"
@@ -40,7 +40,7 @@ md5sums=('51e4ae2c51edf7c145d1b87bec4c344e'
'834b641efbcb45d300630f51f08a9122'
'231a6634fcf774642021377920fffe39'
'cef9d45137b9bd431dce3cbe85ef9bca'
- '509229069300075d1caec9756ab5f5bf')
+ 'e37126cbf6205ef5369ab542c4436044')
build() {
@@ -53,11 +53,19 @@ build() {
#
# Read http://slurm.schedmd.com/quickstart_admin.html for more information
+ ./autogen.sh
./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/slurm-llnl \
- --localstatedir=/var
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/slurm-llnl \
+ --localstatedir=/var \
+ --enable-pam \
+ --with-proctrack \
+ --with-hdf5 \
+ --with-hwloc \
+ --with-rrdtool \
+ --with-ssl \
+ --with-munge
make
}
diff --git a/slurm-llnl.install b/slurm-llnl.install
index 17a84b71daf6..77a897dd2db3 100644
--- a/slurm-llnl.install
+++ b/slurm-llnl.install
@@ -21,16 +21,11 @@ post_install() {
echo -e "\e[34;1m==>\e[39;1m NOTE: You have to create a slurm configuration-file in /etc/slurm-llnl/ \e[0m"
echo -e "\e[34;1m==>\e[39;1m prior to starting any slurm daemons. \e[0m"
- echo -e "\e[34;1m==>\e[39;1m NOTE: In order for new optional dependencies to be taken into account \e[0m"
- echo -e "\e[34;1m==>\e[39;1m slurm-llnl has to be recompiled. \e[0m"
}
## arg 1: the new package version
## arg 2: the old package version
post_upgrade() {
- echo -e "\e[34;1m==>\e[39;1m NOTE: In order for new optional dependencies to be taken into account \e[0m"
- echo -e "\e[34;1m==>\e[39;1m slurm-llnl has to be recompiled. \e[0m"
-
# THIS HAS TO BE REMOVED ONEDAY - TODO
if [ -f /etc/slurm/slurm.conf ]; then
mv /etc/slurm/* /etc/slurm-llnl/