summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD7
3 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c450379a427..304c80ef8faa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = slweb
pkgdesc = Simple static website generator
pkgver = 0.9.4
- pkgrel = 1
+ pkgrel = 2
url = https://strahinja.srht.site/slweb
arch = x86_64
license = GPL3
+ optdepends = katex: For math mode
+ optdepends = git: For {git-log}
+ optdepends = imagemagick: For img tag attributes
source = slweb-0.9.4.tar.gz::https://git.sr.ht/~strahinja/slweb/archive/v0.9.4.tar.gz
md5sums = 911e6746a510c528c18af38245ac04ec
diff --git a/.gitignore b/.gitignore
index ee734601eaf0..19de662f8a70 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,5 @@
*~
*.tar.gz
+*.swp
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index d8355d8cc1d0..8ce29010bf24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,18 @@
# Maintainer: Strahinya Radich <contact@strahinja.org>
pkgname=slweb
pkgver=0.9.4
-pkgrel=1
+pkgrel=2
pkgdesc="Simple static website generator"
arch=('x86_64')
url="https://strahinja.srht.site/slweb"
license=('GPL3')
source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~strahinja/slweb/archive/v$pkgver.tar.gz")
md5sums=('911e6746a510c528c18af38245ac04ec')
+optdepends=(
+ 'katex: For math mode'
+ 'git: For {git-log}'
+ 'imagemagick: For img tag attributes'
+)
package() {
cd $pkgname-v$pkgver