summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD62
-rwxr-xr-xsm64ex.desktop10
-rwxr-xr-xsm64ex.sh4
-rw-r--r--sm64ex.svg1
6 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..319cdd38068f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = sm64ex-redrawn-git
+ pkgdesc = Super Mario 64 PC port (sm64ex fork) with the redrawn texture pack
+ pkgver = r504.58
+ pkgrel = 1
+ url = https://github.com/sm64pc/sm64ex
+ arch = any
+ license = reverse-engineered and unlicensed
+ depends = python
+ depends = audiofile
+ depends = sdl2
+ depends = glew
+ provides = sm64ex
+ conflicts = sm64ex
+ source = git+https://github.com/sm64pc/sm64ex.git
+ source = git+https://github.com/TechieAndroid/sm64redrawn
+ source = sm64ex.desktop
+ source = sm64ex.svg
+ source = sm64ex.sh
+ source = http://localhost/baserom.us.z64
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = 2e8979c01b314d7acce55f246390ff6667700b97da1831c058b16551e7c506886e4c87397266be5f53848016567eb1743cd4b14ff7d186fa2544e3a76d735755
+ sha512sums = af383cb853eb13376bc9697986756b29c15c3c22f8e7da2fec0516f26e12613e209af6f0470eab483bbcf462778af7f01d412c67f5277691e9823dc5bd885a80
+ sha512sums = 7e6cbbac98800a714fc2074027b54aacdbd4bd2ea4f01f09b0fd764b775c2feef6021c1d36ce88703ca1b750cfd381695e7eaafa90d15f5d60b7bfbdfd21fe69
+ sha512sums = SKIP
+
+pkgname = sm64ex-redrawn-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f66213a07689
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.pkg.tar*
+pkg
+src
+sm64ex
+sm64redrawn
+baserom.*.z64
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03df9659e16f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+# Contributor: Hekuran https://github.com/narukeh
+
+# A legally obtained copy of the Super Mario 64 ROM should be included
+# The US version should have a sha1sum of 9bef1128717f958171a4afac3ed78ee2bb4e86ce
+
+_region=us
+_pkgname=sm64ex
+pkgname=$_pkgname-redrawn-git
+pkgver=r504.58
+pkgrel=1
+pkgdesc='Super Mario 64 PC port (sm64ex fork) with the redrawn texture pack'
+arch=('any')
+url='https://github.com/sm64pc/sm64ex'
+license=('reverse-engineered and unlicensed')
+depends=('python' 'audiofile' 'sdl2' 'glew')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+source=(
+ 'git+https://github.com/sm64pc/sm64ex.git'
+ 'git+https://github.com/TechieAndroid/sm64redrawn'
+ "$_pkgname.desktop"
+ "$_pkgname.svg"
+ "$_pkgname.sh"
+ "http://localhost/baserom.$_region.z64"
+)
+
+sha512sums=(
+ 'SKIP'
+ 'SKIP'
+ '2e8979c01b314d7acce55f246390ff6667700b97da1831c058b16551e7c506886e4c87397266be5f53848016567eb1743cd4b14ff7d186fa2544e3a76d735755'
+ 'af383cb853eb13376bc9697986756b29c15c3c22f8e7da2fec0516f26e12613e209af6f0470eab483bbcf462778af7f01d412c67f5277691e9823dc5bd885a80'
+ '7e6cbbac98800a714fc2074027b54aacdbd4bd2ea4f01f09b0fd764b775c2feef6021c1d36ce88703ca1b750cfd381695e7eaafa90d15f5d60b7bfbdfd21fe69'
+ 'SKIP'
+)
+
+pkgver() {
+ cd sm64redrawn
+ redrawn_version=$(git rev-list --count HEAD)
+ cd ../$_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$redrawn_version"
+}
+
+prepare() {
+ cd $_pkgname
+ cp ../baserom.$_region.z64 .
+}
+
+build() {
+ cd $_pkgname
+ make VERSION=$_region BETTERCAMERA=1 NODRAWINGDISTANCE=1 TEXTURE_FIX=1 EXTERNAL_DATA=1 ${MAKEFLAGS:--j$(nproc)}
+}
+
+package() {
+ install -Dm755 $_pkgname.sh "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm755 $_pkgname.svg "$pkgdir/usr/share/pixmaps/$_pkgname.svg"
+ install -Dm755 $_pkgname/build/${_region}_pc/sm64.${_region}.* "$pkgdir/usr/share/$_pkgname/$_pkgname"
+ install -Dm644 $_pkgname/build/${_region}_pc/res/base.zip "$pkgdir/usr/share/$_pkgname/res/base.zip"
+ cp -r --no-preserve=owner sm64redrawn/gfx "$pkgdir/usr/share/$_pkgname/res/"
+}
diff --git a/sm64ex.desktop b/sm64ex.desktop
new file mode 100755
index 000000000000..3af4a9ac9071
--- /dev/null
+++ b/sm64ex.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Super Mario 64
+GenericName=Super Mario 64
+Comment=A full decompilation of Super Mario 64
+Exec=sm64ex
+Icon=sm64ex
+Terminal=false
+Type=Application
+Categories=Game;Retro;Emulator;
diff --git a/sm64ex.sh b/sm64ex.sh
new file mode 100755
index 000000000000..af1ae133f2eb
--- /dev/null
+++ b/sm64ex.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/env bash
+
+cd /usr/share/sm64ex || exit
+./sm64ex
diff --git a/sm64ex.svg b/sm64ex.svg
new file mode 100644
index 000000000000..52f0f9c6ec57
--- /dev/null
+++ b/sm64ex.svg
@@ -0,0 +1 @@
+<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 10883.2 10883.2"><path d="M10441.7 6116.116l-616.3-870.8c-14.2-20.2-36.6-33.5-61.2-36.5l-610.8-74.3 168.5-71.4c18.6-7.8 30.9-26.3 30.9-46.5v-312.6c0-21.1-9.5-41.4-25.6-55.2l-213.1-181.6c6.6-4.3 11.4-11.1 12.6-18.9l126-761.4c3.6-22 5.5-44.3 5.5-66.5v-182.3c0-20.7-11-39.9-28.9-50.4l-684.4-403c-18.6-11-40.5-15.2-62-11.9l-1015 155.2c-19.1 2.8-33.1 19.3-33.1 38.5v64.6l-1037.5-180.7c-18.8-3.2-37.1 8.2-42.3 26.5l-64 224.8-493.4-266.1c-18.9-10.3-41-13.7-62.3-9.9l-1006.3 185.4c-19.1 3.6-33 20.2-33 39.6v182.2c0 3.3.3 6.6.3 9.9l-616.7-82v-142.9c0-19-14.4-34.9-33.3-36.7l-911.9-85.3c-18.3-1.7-34.2 12-35.5 30.3l-4.7 75-378.5-289.8c-17-13-38.5-19.2-59.8-17.2l-778.9 74.3c-21 2-40.1 13.4-51.9 31.1l-418.8 625c-12.1 18.1-18.6 39.4-18.6 61.3v294.2c0 20.7 10.9 40.1 28.6 51l132.7 80.7-210 279.8c-13.1 17.3-20 38.5-20 60.3l.2 289.7c0 21.2 10.4 40.2 25.6 55.1l198.3 168.8-551.8-73.4c-22.9-3.1-45 9.5-53.9 30.7l-922.1 2156.6c-10.3 23.7-15.3 49.1-15.3 74.8v254.4c0 23.6 14 45 35.8 54.2l1063.7 454.1c19.1 8.2 41-2.1 47.2-21.9l289.9-946.2 254.8 457.9c9.1 16.2 31.9 18.3 43.5 3.8l332.1-407.7 56.8 948.9c1.3 20.6 20.3 35.2 40.4 31l909.1-187.9 626.6 118.5c21 3.9 41.2-10.1 44.6-31.2l78.7-466.4 327.5-49.2 104.9 505.5c4.4 21.1 24.9 34.9 46.1 30.9l717.4-135.7 10.6 91c2.4 21.5 21.6 37.1 43.2 35.2l861-77.7c21.9-2 38.8-20.3 38.6-42.4l-.5-249.5 248.1 378.7c12.3 18.8 36.4 25.9 56.9 16.6l631.4-282.7-3.9 225.5c-.3 20.9 17.2 37.7 38 36.2l834.5-57.2c22.9-1.5 41.8-18.5 45.7-41l107.1-603.8 143.1 412.6c8 23.1 26.5 41.2 49.8 48.9l1002 326.8c23.7 7.8 49.7 6.3 72.4-4.1l951.4-434c22.4-10.2 39-30.1 45-53.9l261.4-1034.2c6.3-25.2 9.5-51 9.5-76.7v-194.7c-.2-25.2-8.1-50-22.7-70.7z"/><path d="M9153.2 4697.016l-460.8-392.6 272.9-170c14.5-9 24.5-23.8 27.1-40.6l97.2-586c2.5-15.9-4.9-31.8-18.8-40l-561.7-330.8c-15-8.8-32.5-12.1-49.5-9.5l-835.1 127.9c-5.2.8-9.6 3.4-13.4 6.5l104 18.1c18.3 3.1 30.4 20.4 27.5 38.7l-86 512.4 112.2 1092.9c1.6 14.8 14.5 25.6 29.3 24.3l406.8-35.7c15-1.3 26.3-14 25.9-29.1l-16.2-526.6 19.7-3.9 372.3 573c8.5 13 24.9 18.1 39.3 12l503.2-213c11.2-5 13.6-20 4.1-28zm-628.9-648.9l-318.3 51.1-16.4-555.2 390 137.8z" fill="#fccf00"/><path d="M7464.7 4453.416l-604.1 89.3-43.2-296.8 487.7 73.7c10.6 1.7 20.3-5.8 21.8-16.3l42.4-324.3c1.4-10.3-6.6-19.5-16.9-19.6l-501.9-7.5 76.2-279 557 168.5c9.9 2.9 20.2-3.4 21.9-13.6l67.2-401.1c1.7-10.7-5.4-20.7-15.9-22.6l-1066.6-185.8c-10.9-1.8-21.5 4.8-24.6 15.5l-39.9 140.6 64.8 35c17.7 9.5 27.6 29.2 24.8 49.1l-103.5 702.5c-3.2 21.4-13.4 41.3-29 56.2l-163.1 156 77.9 481.7c1.7 11.1 11.2 19.4 22.6 19.8l1215.4 43.1c10.1.3 18-8.7 16.6-18.6l-65.3-429.4c-1.6-10.7-11.7-18.1-22.3-16.4z" fill="#44af35"/><path d="M6333.5 3494.516l-566.5-305.6c-15.3-8.1-33-11-50-7.8l-829.4 152.8c-14.8 2.8-24.9 16.6-23 31.5l12.1 101.3 105.7 14.1c18.1 2.4 30.6 19.3 27.6 37.4l-73.8 438.8 115.5 954.3c1.7 14.8 15 25.5 29.8 24l416.4-41.9c14.8-1.5 25.9-14.5 24.9-29.4l-24-391.1 398.1-21.9c17.2-.9 33.6-8 46.1-20l304.1-290.9c12.6-12 20.7-27.9 23.3-45l82.5-561.3c2.6-15.9-5.3-31.7-19.4-39.3zm-540.2 565.5l-316.3 55.4-32.8-531.6 403.2 139.1z" fill="#e62310"/><path d="M4815.9 3609.416l-612.8-81.3c-13.7-1.9-25.9 9.2-25.2 23.3l36.9 818.3-483.8 31.3 171.1-1056.2c2.4-14.4-7.9-27.5-22.4-28.9l-612.4-57.3c-14.7-1.4-27.4 9.5-28.4 24.2l-1.7 28 68.1 52.1c17 13.1 28.1 32.5 30.6 53.6l3.8 30.6c2.7 21.2-3.3 42.7-16.6 59.5l-106.8 135.5-28.2 450.4 39.8 26.2c18 11.8 30.9 30 36.1 50.9l6.2 24.4c5.4 21 3.5 43.3-5.2 63.1l-101.4 229.8-1.4 20.8c-1.1 16.9 5.7 33.4 18.3 44.6l351.8 316.2c12.8 11.5 29.3 18.1 46.5 18.6l771.2 19.7c17 .4 33.3-6.8 44.5-19.4l271.3-309.5c11.5-13.1 19.2-29.3 22.1-46.5l150.1-892.1c2.5-14.4-7.4-28-22.1-29.9z" fill="#fccf00"/><path d="M2415 3446.916l474.5 325.4c12.3 8.5 29.3 5.9 38.5-5.8l231.2-293.3c9.2-11.6 6.9-28.4-4.7-37.3l-488.3-374.1c-13.6-10.5-30.9-15.5-48-13.8l-663.1 63.2c-16.9 1.7-32 10.9-41.5 24.8l-353.3 527.1c-8 12.1-4.4 28.6 8 36.2l862.4 525.2-176.4 239.8-459.5-386.9c-11-9.4-27.8-7.4-36.4 4.1l-268.6 357.9c-9 12.1-7.1 29 4.3 38.8l472.8 402.1c13.1 11.2 30 17.2 47.2 16.9l784.5-13.8c16.2-.3 30.9-10 37.5-24.9l269.3-609.8c6.3-14.2 1.4-30.7-11.5-39.3l-816.2-537.3z" fill="#009bd9"/><path d="M10254.9 6158.216l-533-753.2c-11.5-16.2-29.3-26.8-49.1-29.2l-1038.7-126.4c-19.2-2.4-38.3 5.5-50.3 20.7l-458.2 579.2-128.7 728.3 216.9 625.4c6.3 18.5 21.1 33 39.8 39l867.9 283c18.9 6.2 39.7 5 57.9-3.2l825.8-376.6c17.8-8.2 31.1-24.1 36-43.1l224.3-888.2c4.7-19.2.9-39.7-10.6-55.7zm-1219.5 624.3l-348.5-368.8 250.7-430.6 464.7 124.7 57.6 463.8z" fill="#44af35"/><path d="M8003.4 5344.716l-793.1-189.7c-15.8-3.8-30.9 7.7-31.5 23.8l-67.5 1773.3 97.6 81.1c18.6 15.5 28.1 39.6 24.8 63.4l-12.8 91.3c-3.3 23.9-18.8 44.6-40.9 54.4l-81.4 36.4-4.9 128.7c-.5 16.7 13.4 30.1 30 29.1l515.8-35.4c18.3-1.3 33.4-14.8 36.6-32.7l352.2-1985.7c3-17.2-7.8-33.9-24.9-38z" fill="#009bd9"/><path d="M7007.1 7095.416l-612-507.7 388.5-226.8c17.2-9.9 29.2-26.9 32.8-46.3l135.5-704.9c3.6-18.3-4.9-36.9-21-46.4l-788.7-460.6c-17.3-10.2-37.9-14-57.6-10.7l-1114.6 180.5c-17.2 2.8-29.2 18.6-27.1 35.9l154.9 1334.4 269.6 774 391.5-35.3c17.4-1.6 30.4-16.5 29.8-33.9l-24.4-690.7 26-5.3 499.3 762.1c9.8 15 29.2 20.6 45.4 13.3l667.6-298.9c13.2-5.9 15.5-23.5 4.5-32.7zm-847.9-872.2l-407.4 94.9-23.5-656.3 483 130.5z" fill="#fccf00"/><path d="M5126.7 7262.916l-676.1-1942c-6.3-17.8-22.4-30.7-41.3-32.6l-925.5-95c-17.8-1.7-34.5 9.5-39.6 26.8l-305.3 1053.7 226.7 1123.7 197.3 37.4c16.9 3.2 33-8 35.8-24.9l71.3-422.6 619.6-93.1 105.1 506.7c3.5 17 20 28 36.9 24.7l674.7-127.5c16.1-3 25.7-19.7 20.4-35.3zm-1362.6-833.8l100.8-598.2 207.1 16.4 124.3 597.2z" fill="#44af35"/><path d="M2761.5 5298.716c-3.6-18.2-18.6-32.3-36.9-34.7l-507.5-68.5c-18.5-2.5-36.6 6.9-45.3 23.4l-336.5 651.2-231.6-690.3c-6-18-21.9-31.2-40.7-33.6l-469.9-62.5c-18.1-2.4-36 7.7-43.2 24.5l-827.2 1935.9c-6.9 15.7.5 34 16.2 40.9l756.2 322.7c15.3 6.6 32.8-1.6 37.7-17.5l356.3-1162.6 333.6 599.5c7.1 13 25.2 14.6 34.7 3l458.7-563.2 72.1 1205.6c1 16.4 16.2 28.1 32.3 24.8l819.3-169.3c16.9-3.5 27.6-20 24.3-36.8z" fill="#e62310"/><g><path d="M10470.5 7460.616v240.6h39.8v-240.6h93.2v-39.8h-226.2v39.8zM10758.2 7602.216l-85.3-181.4h-39.7v280.4h39.7v-185.3h2.1l66.5 139h33.3l66.6-139h2v185.3h39.8v-280.4h-39.8z"/></g></svg> \ No newline at end of file