summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 40169b8b1014..1c873a8b0734 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,13 @@ arch=('i686' 'x86_64')
license=('gpl')
depends=('coreutils')
replaces=('smbclient')
+url='http://google.com'
conflicts=($replaces)
provides=($replaces)
source=()
md5sums=()
package() {
- mkdir "${pkgdir}"/usr/lib/ -p
- ln -s /usr/lib/coreutils/libstdbuf.so "${pkgdir}"/usr/lib/libsmbclient.so.0
+ mkdir "${pkgdir}"/usr/lib/ -p
+ echo "smbc_chmod smbc_close smbc_closedir smbc_creat smbc_fgetxattr smbc_flistxattr smbc_free_context smbc_fremovexattr smbc_fsetxattr smbc_fstat smbc_fstatvfs smbc_ftruncate smbc_getDebug smbc_getdents smbc_getFunctionAddCachedServer smbc_getFunctionAuthData smbc_getFunctionAuthDataWithContext smbc_getFunctionCheckServer smbc_getFunctionChmod smbc_getFunctionClose smbc_getFunctionClosedir smbc_getFunctionCreat smbc_getFunctionFstat smbc_getFunctionFstatdir smbc_getFunctionFstatVFS smbc_getFunctionFtruncate smbc_getFunctionGetCachedServer smbc_getFunctionGetdents smbc_getFunctionGetxattr smbc_getFunctionListPrintJobs smbc_getFunctionListxattr smbc_getFunctionLseek smbc_getFunctionLseekdir smbc_getFunctionMkdir smbc_getFunctionNotify smbc_getFunctionOpen smbc_getFunctionOpendir smbc_getFunctionOpenPrintJob smbc_getFunctionPrintFile smbc_getFunctionPurgeCachedServers smbc_getFunctionRead smbc_getFunctionReaddir smbc_getFunctionRemoveCachedServer smbc_getFunctionRemoveUnusedServer smbc_getFunctionRemovexattr smbc_getFunctionRename smbc_getFunctionRmdir smbc_getFunctionSetxattr smbc_getFunctionSplice smbc_getFunctionStat smbc_getFunctionStatVFS smbc_getFunctionTelldir smbc_getFunctionUnlink smbc_getFunctionUnlinkPrintJob smbc_getFunctionUtimes smbc_getFunctionWrite smbc_getNetbiosName smbc_getOptionBrowseMaxLmbCount smbc_getOptionCaseSensitive smbc_getOptionDebugToStderr smbc_getOptionFallbackAfterKerberos smbc_getOptionFullTimeNames smbc_getOptionNoAutoAnonymousLogin smbc_getOptionOneSharePerServer smbc_getOptionOpenShareMode smbc_getOptionSmbEncryptionLevel smbc_getOptionUrlEncodeReaddirEntries smbc_getOptionUseCCache smbc_getOptionUseKerberos smbc_getOptionUseNTHash smbc_getOptionUserData smbc_getPort smbc_getServerCacheData smbc_getTimeout smbc_getUser smbc_getWorkgroup smbc_getxattr smbc_init smbc_init_context smbc_lgetxattr SMBCLIENT_0.1.0 SMBCLIENT_0.2.0 SMBCLIENT_0.2.1 SMBCLIENT_0.2.2 SMBCLIENT_0.2.3 smbc_list_print_jobs smbc_listxattr smbc_llistxattr smbc_lremovexattr smbc_lseek smbc_lseekdir smbc_lsetxattr smbc_mkdir smbc_new_context smbc_notify smbc_open smbc_opendir smbc_open_print_job smbc_option_get smbc_option_set smbc_print_file smbc_read smbc_readdir smbc_removexattr smbc_rename smbc_rmdir smbc_set_context smbc_set_credentials smbc_set_credentials_with_fallback smbc_setDebug smbc_setFunctionAddCachedServer smbc_setFunctionAuthData smbc_setFunctionAuthDataWithContext smbc_setFunctionCheckServer smbc_setFunctionChmod smbc_setFunctionClose smbc_setFunctionClosedir smbc_setFunctionCreat smbc_setFunctionFstat smbc_setFunctionFstatdir smbc_setFunctionFstatVFS smbc_setFunctionFtruncate smbc_setFunctionGetCachedServer smbc_setFunctionGetdents smbc_setFunctionGetxattr smbc_setFunctionListPrintJobs smbc_setFunctionListxattr smbc_setFunctionLseek smbc_setFunctionLseekdir smbc_setFunctionMkdir smbc_setFunctionNotify smbc_setFunctionOpen smbc_setFunctionOpendir smbc_setFunctionOpenPrintJob smbc_setFunctionPrintFile smbc_setFunctionPurgeCachedServers smbc_setFunctionRead smbc_setFunctionReaddir smbc_setFunctionRemoveCachedServer smbc_setFunctionRemoveUnusedServer smbc_setFunctionRemovexattr smbc_setFunctionRename smbc_setFunctionRmdir smbc_setFunctionSetxattr smbc_setFunctionSplice smbc_setFunctionStat smbc_setFunctionStatVFS smbc_setFunctionTelldir smbc_setFunctionUnlink smbc_setFunctionUnlinkPrintJob smbc_setFunctionUtimes smbc_setFunctionWrite smbc_setNetbiosName smbc_setOptionBrowseMaxLmbCount smbc_setOptionCaseSensitive smbc_setOptionDebugToStderr smbc_setOptionFallbackAfterKerberos smbc_setOptionFullTimeNames smbc_setOptionNoAutoAnonymousLogin smbc_setOptionOneSharePerServer smbc_setOptionOpenShareMode smbc_setOptionSmbEncryptionLevel smbc_setOptionUrlEncodeReaddirEntries smbc_setOptionUseCCache smbc_setOptionUseKerberos smbc_setOptionUseNTHash smbc_setOptionUserData smbc_setPort smbc_setServerCacheData smbc_setTimeout smbc_setUser smbc_setWorkgroup smbc_setxattr smbc_stat smbc_statvfs smbc_telldir smbc_unlink smbc_unlink_print_job smbc_urldecode smbc_urlencode smbc_utime smbc_utimes smbc_version smbc_write" | perl -nwE 'for(split " ",$_){say "void $_(){}"}' |grep -v SMBCLIENT|gcc -shared -o "${pkgdir}"/usr/lib/libsmbclient.so.0 -xc -
}