summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0001_settings.patch34
-rw-r--r--PKGBUILD11
3 files changed, 45 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0592b3382d1..52fd5856f9fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = smuxi
pkgdesc = User-friendly and cross-platform IRC client for sophisticated users for GNOME/GTK+
pkgver = 1.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://smuxi.im/
arch = any
license = GPL
@@ -14,9 +14,11 @@ pkgbase = smuxi
options = !emptydirs
source = https://smuxi.im/jaws/data/files/smuxi-1.2.1.tar.gz
source = https://smuxi.im/jaws/data/files/smuxi-1.2.1.tar.gz.asc
+ source = 0001_settings.patch
validpgpkeys = A3712C8E4CE449B9F28C563F33A429E62D907822
sha256sums = cb96475e4ec3479b37b4357178cb00a1a404a67ba24d5fc0f6c4fd3fae5816e5
sha256sums = SKIP
+ sha256sums = 13b90091331972f57e290d838bc2d524bf63cc8c3b1cf91d9fa31d749307ae3e
pkgname = smuxi-server
pkgdesc = User-friendly and cross-platform IRC client for sophisticated users for GNOME/GTK+ (common files and server)
diff --git a/0001_settings.patch b/0001_settings.patch
new file mode 100644
index 000000000000..7475e5af171a
--- /dev/null
+++ b/0001_settings.patch
@@ -0,0 +1,34 @@
+commit fb27ee910dd22d571291484b7867fab123973681
+Author: Mirco Bauer <meebey@meebey.net>
+Date: Sun May 7 09:28:07 2023 +0800
+
+ Engine: fix UserConfig.SetAll() discarding all passed settings
+
+ Due to the abstraction the input to UserConfig.SetAll() expects
+ non-prefixed config keys while _Config.SetAll() expects them prefixed.
+
+ This mismatch in key structure lead to losing/discarding all pushed
+ settings. Prepending _UserPrefix fixes this issue and resolves GH-296.
+
+diff --git a/src/Engine/Config/UserConfig.cs b/src/Engine/Config/UserConfig.cs
+index 7f4a8b41..c6c7825b 100644
+--- a/src/Engine/Config/UserConfig.cs
++++ b/src/Engine/Config/UserConfig.cs
+@@ -1,7 +1,7 @@
+ /*
+ * Smuxi - Smart MUltipleXed Irc
+ *
+- * Copyright (c) 2005-2006, 2010-2011, 2013, 2015, 2017 Mirco Bauer <meebey@meebey.net>
++ * Copyright (c) 2005-2006, 2010-2011, 2013, 2015, 2017, 2021, 2023 Mirco Bauer <meebey@meebey.net>
+ *
+ * Full GPL License: <http://www.gnu.org/licenses/gpl.txt>
+ *
+@@ -176,7 +176,7 @@ namespace Smuxi.Engine
+ continue;
+ }
+
+- filteredSettings.Add(setting.Key, setting.Value);
++ filteredSettings.Add(_UserPrefix + setting.Key, setting.Value);
+ // update entry in cache
+ if (IsCaching) {
+ _Cache[setting.Key] = setting.Value;
diff --git a/PKGBUILD b/PKGBUILD
index 91d3b2f848d3..023af4a8d9cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,26 @@
pkgbase=smuxi
pkgname=('smuxi-server' 'smuxi')
pkgver=1.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="User-friendly and cross-platform IRC client for sophisticated users for GNOME/GTK+"
arch=('any')
url="https://smuxi.im/"
license=('GPL')
makedepends=('notify-sharp' 'log4net' 'nini' 'gtkspell' 'stfl' 'intltool')
options=('!emptydirs')
-source=(https://smuxi.im/jaws/data/files/$pkgbase-$pkgver.tar.gz{,.asc})
+source=(https://smuxi.im/jaws/data/files/$pkgbase-$pkgver.tar.gz{,.asc}
+ 0001_settings.patch)
validpgpkeys=('A3712C8E4CE449B9F28C563F33A429E62D907822') # Mirco Bauer
sha256sums=('cb96475e4ec3479b37b4357178cb00a1a404a67ba24d5fc0f6c4fd3fae5816e5'
- 'SKIP')
+ 'SKIP'
+ '13b90091331972f57e290d838bc2d524bf63cc8c3b1cf91d9fa31d749307ae3e')
prepare() {
cd $pkgbase-$pkgver
sed -i 's|$(datarootdir)/appdata|$(datarootdir)/metainfo|' src/Frontend-GNOME/Makefile.{am,in}
+
+ # Patch for not applied settings
+ patch -Np1 -i "$srcdir"/0001_settings.patch
}
build() {