summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..285140b716fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = snapcraft-gui
+ pkgdesc = Graphical user interface to create snaps using Snapcraft as the backend
+ pkgver = 3.0
+ pkgrel = 1
+ url = http://snapcraft.io/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = snapcraft
+ depends = tree
+ optdepends = pastebinit: pastebin.com integration
+ source = https://github.com/snapcraft-gui/snapcraft-gui/releases/download/3.0/snapcraft-gui_3.0.tar.xz
+ md5sums = 98da2545d1b01c6f74fb463cb2e1b89e
+
+pkgname = snapcraft-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07b78a06fb97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ethan Kiang <chocopuff298+arch@gmail.com>
+# Contributor: Lari Tikkanen <lartza@wippies.com>
+# Contributor: Stefan Stojanovic <eastapolo00@yahoo.com>
+pkgname=snapcraft-gui
+pkgver=3.0
+pkgrel=1
+pkgdesc="Graphical user interface to create snaps using Snapcraft as the backend"
+arch=('i686' 'x86_64')
+url="http://snapcraft.io/"
+license=('GPL')
+depends=('qt5-base' 'snapcraft' 'tree')
+optdepends=('pastebinit: pastebin.com integration')
+source=(https://github.com/snapcraft-gui/snapcraft-gui/releases/download/${pkgver}/snapcraft-gui_${pkgver}.tar.xz)
+md5sums=('98da2545d1b01c6f74fb463cb2e1b89e')
+
+build() {
+cd "${srcdir}/build"
+qmake
+make
+}
+
+package() {
+cd "${srcdir}/build"
+
+#Binaries
+install -Dm 755 ./snapcraft-gui "$pkgdir/usr/bin/snapcraft-gui"
+}
+