summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--snapd.install12
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 101744521cda..adc5c30c6849 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = snapd
pkgdesc = Service and tools for management of snap packages.
- pkgver = 2.61.3
+ pkgver = 2.62
pkgrel = 1
url = https://github.com/snapcore/snapd
install = snapd.install
@@ -29,7 +29,7 @@ pkgbase = snapd
options = !strip
options = emptydirs
options = !lto
- source = snapd-2.61.3.tar.xz::https://github.com/snapcore/snapd/releases/download/2.61.3/snapd_2.61.3.vendor.tar.xz
- sha256sums = 90d427ca0a0e1306e647c6091176fba678522e2af04228aa274a34d011c82123
+ source = snapd-2.62.tar.xz::https://github.com/snapcore/snapd/releases/download/2.62/snapd_2.62.vendor.tar.xz
+ sha256sums = e4bcf0d7677afdcb7256958fd382a5aad71db13474c08e5828e913614ee88ea8
pkgname = snapd
diff --git a/PKGBUILD b/PKGBUILD
index 7fee6a6f0e46..da84ee83608b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd' 'apparmor')
optdepends=('bash-completion: bash completion support'
'xdg-desktop-portal: desktop integration')
-pkgver=2.61.3
+pkgver=2.62
pkgrel=1
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://github.com/snapcore/snapd"
@@ -20,7 +20,7 @@ install=snapd.install
source=(
"$pkgname-$pkgver.tar.xz::https://github.com/snapcore/${pkgname}/releases/download/${pkgver}/${pkgname}_${pkgver}.vendor.tar.xz"
)
-sha256sums=('90d427ca0a0e1306e647c6091176fba678522e2af04228aa274a34d011c82123')
+sha256sums=('e4bcf0d7677afdcb7256958fd382a5aad71db13474c08e5828e913614ee88ea8')
_gourl=github.com/snapcore/snapd
diff --git a/snapd.install b/snapd.install
index c15e589ed49d..9b7815dd21ae 100644
--- a/snapd.install
+++ b/snapd.install
@@ -1,4 +1,4 @@
-pre_remove() {
+ pre_remove() {
/usr/lib/snapd/snap-mgmt --purge || :
rm -f /etc/udev/rules.d/70-snap.*.rules || true
rm -f /etc/dbus-1/system.d/snap.* || true
@@ -8,6 +8,16 @@ pre_remove() {
post_upgrade() {
# since 2.39+ void permission bits are 111 instead of 000
chmod 111 /var/lib/snapd/void || true
+ # since 2.62, snapd generates cgroup device files under /var/lib/snapd/cgroup/
+ # which are needed in order to start any snaps, suggest to restart snapd if
+ # we're upgrading from a version older than 2.62
+ if (( $(vercmp "$2" '2.62-1') < 0)); then
+ echo
+ echo ">>> The snapd.service requires a restart for snaps to continue working. "
+ echo ">>> Run the following command after the update:"
+ echo ">>> systemctl restart snapd.service"
+ echo
+ fi
}
# vim:set ts=2 sw=2 et: