summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9eee077dc30..b0af02dc3727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = snapd
pkgdesc = Service and tools for management of snap packages.
pkgver = 2.37.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/snapcore/snapd
install = snapd.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9564f6635308..3ba595a16654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service and tools for management of snap packages."
depends=('squashfs-tools' 'libseccomp' 'libsystemd' 'apparmor')
optdepends=('bash-completion: bash completion support')
pkgver=2.37.3
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'i686')
url="https://github.com/snapcore/snapd"
license=('GPL3')
@@ -60,6 +60,7 @@ build() {
# build snap-exec and snap-update-ns completely static for base snaps
go build "${staticflags[@]}" -o "$GOPATH/bin/snap-update-ns" "${_gourl}/cmd/snap-update-ns"
go build "${staticflags[@]}" -o "$GOPATH/bin/snap-exec" "${_gourl}/cmd/snap-exec"
+ go build "${staticflags[@]}" -o "$GOPATH/bin/snapctl" "${_gourl}/cmd/snapctl"
# Generate data files such as real systemd units, dbus service, environment
# setup helpers out of the available templates
@@ -109,12 +110,14 @@ package() {
# Install executables
install -Dm755 "$GOPATH/bin/snap" "$pkgdir/usr/bin/snap"
- install -Dm755 "$GOPATH/bin/snapctl" "$pkgdir/usr/bin/snapctl"
+ install -Dm755 "$GOPATH/bin/snapctl" "$pkgdir/usr/lib/snapd/snapctl"
install -Dm755 "$GOPATH/bin/snapd" "$pkgdir/usr/lib/snapd/snapd"
install -Dm755 "$GOPATH/bin/snap-seccomp" "$pkgdir/usr/lib/snapd/snap-seccomp"
install -Dm755 "$GOPATH/bin/snap-failure" "$pkgdir/usr/lib/snapd/snap-failure"
install -Dm755 "$GOPATH/bin/snap-update-ns" "$pkgdir/usr/lib/snapd/snap-update-ns"
install -Dm755 "$GOPATH/bin/snap-exec" "$pkgdir/usr/lib/snapd/snap-exec"
+ # snapctl is run from inside the snap
+ ln -s /usr/lib/snapd/snapctl "$pkgdir/usr/bin/snapctl"
# pre-create directories
install -dm755 "$pkgdir/var/lib/snapd/snap"