summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
-rw-r--r--conf-d.patch49
-rw-r--r--cron-rename.patch14
-rw-r--r--drift-file-path.patch10
-rw-r--r--usr-paths.patch12
6 files changed, 122 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7355c7668e74..edf227c841b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = snapper-git
pkgdesc = A tool for managing BTRFS and LVM snapshots. It can create, diff and restore snapshots and provides timelined auto-snapping.
- pkgver = 0.4.5.git.1328.13fb9c1
+ pkgver = 0.10.3.git.2211.03a6f3b
pkgrel = 1
url = http://snapper.io
- arch = i686
arch = x86_64
+ arch = aarch64
license = GPL2
makedepends = boost
makedepends = lvm2
@@ -18,11 +18,20 @@ pkgbase = snapper-git
depends = dbus
depends = boost-libs
depends = acl
+ depends = json-c
+ optdepends = pam: pam_snapper
provides = snapper
conflicts = snapper
backup = etc/conf.d/snapper
source = snapper::git+https://github.com/openSUSE/snapper.git
- sha512sums = SKIP
+ source = conf-d.patch
+ source = cron-rename.patch
+ source = drift-file-path.patch
+ source = usr-paths.patch
+ sha256sums = SKIP
+ sha256sums = 267118a198583fc1ff10f376e108c0600844e0b1370e44ac4674b20332bff106
+ sha256sums = 0e76f2aef9ac05d719e25c2d60e7eba4b533778a57fe98fd047f256c6845f65f
+ sha256sums = 093c7993e466a0cf9c0794a971825f5f1b40047512857bc124ed0d63dbb306d6
+ sha256sums = 710da7638a1c123a6985398a15cd7c03432fc3b2d781e2d7a20a1a52669eed95
pkgname = snapper-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 45530d7c7b23..993a8f3a9de5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
-# Maintainer: Tom Kuther <archlinux@kuther.net>
-# Co-Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
+# Maintainer: Sravan Pannala <sradjoker@endeavouros.com>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Tom Kuther <gimpel@sonnenkinder.org>
+# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
pkgname=snapper-git
_gitname=snapper
@@ -8,14 +10,23 @@ pkgrel=1
pkgdesc="A tool for managing BTRFS and LVM snapshots. It can create, diff and restore snapshots and provides timelined auto-snapping."
provides=('snapper')
conflicts=('snapper')
-arch=('i686' 'x86_64')
+arch=('x86_64' 'aarch64')
url="http://snapper.io"
license=('GPL2')
-depends=('btrfs-progs' 'libxml2' 'dbus' 'boost-libs' 'acl')
+depends=('btrfs-progs' 'libxml2' 'dbus' 'boost-libs' 'acl' 'json-c')
makedepends=('boost' 'lvm2' 'libxslt' 'docbook-xsl' 'pam' 'git' 'systemd')
+optdepends=('pam: pam_snapper')
backup=('etc/conf.d/snapper')
-source=('snapper::git+https://github.com/openSUSE/snapper.git')
-sha512sums=('SKIP')
+source=("snapper::git+https://github.com/openSUSE/snapper.git"
+ "conf-d.patch"
+ "cron-rename.patch"
+ "drift-file-path.patch"
+ "usr-paths.patch")
+sha256sums=('SKIP'
+ '267118a198583fc1ff10f376e108c0600844e0b1370e44ac4674b20332bff106'
+ '0e76f2aef9ac05d719e25c2d60e7eba4b533778a57fe98fd047f256c6845f65f'
+ '093c7993e466a0cf9c0794a971825f5f1b40047512857bc124ed0d63dbb306d6'
+ '710da7638a1c123a6985398a15cd7c03432fc3b2d781e2d7a20a1a52669eed95')
pkgver() {
cd "$_gitname"
@@ -24,24 +35,10 @@ pkgver() {
prepare() {
cd "$_gitname"
-
- # cron names
- sed -e 's@suse.de-snapper@snapper@g' -i scripts/Makefile.am
-
- # fix sysconf dir
- sed -e 's@/etc/sysconfig@/etc/conf.d@g' -i scripts/*snapper*
-
- # fix pam plugin install location
- sed -i -e 's@shell echo /@shell echo /usr/@g' pam/Makefile.am
-
- # all in /usr/bin
- sed -i -e 's@/usr/sbin@/usr/bin@g' data/org.opensuse.Snapper.service
-
- # NTP drift file location
- sed -i -e 's@/var/lib/ntp/drift/ntp.drift@/var/lib/ntp/ntp.drift@' data/base.txt
-
- # man pages sysconfig location
- sed -i -e 's@/etc/sysconfig@/etc/conf.d@g' doc/*
+ patch -p1 -i "$srcdir/conf-d.patch"
+ patch -p1 -i "$srcdir/cron-rename.patch"
+ patch -p1 -i "$srcdir/drift-file-path.patch"
+ patch -p1 -i "$srcdir/usr-paths.patch"
}
build() {
@@ -55,6 +52,7 @@ build() {
./configure --prefix=/usr \
--sbindir=/usr/bin \
--with-conf=/etc/conf.d \
+ --with-pam-security=/usr/lib/security \
--disable-zypp \
--disable-silent-rules
make
@@ -66,4 +64,6 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 data/sysconfig.snapper \
"$pkgdir"/etc/conf.d/snapper
+
+ rm -rf "$pkgdir/usr/lib/snapper/testsuite/"
}
diff --git a/conf-d.patch b/conf-d.patch
new file mode 100644
index 000000000000..6dd92c0d7364
--- /dev/null
+++ b/conf-d.patch
@@ -0,0 +1,49 @@
+diff --git a/scripts/pam_snapper_userdel.sh b/scripts/pam_snapper_userdel.sh
+index 30be9be..1ffa63e 100755
+--- a/scripts/pam_snapper_userdel.sh
++++ b/scripts/pam_snapper_userdel.sh
+@@ -40,7 +40,7 @@ fi
+ if [ ${DRYRUN} == 0 ] ; then
+ # Delete the snapper configuration
+ # This deletes $SNAPPERCFGDIR/home_${MYUSER}
+- # removes "home_${MYUSER}" from /etc/sysconfig/snapper
++ # removes "home_${MYUSER}" from /etc/conf.d/snapper
+ # and deletes all snapshots
+ ${CMD_SNAPPER} -c home_${MYUSER} delete-config
+ # Delete the USER's home subvolume
+diff --git a/scripts/snapper-daily b/scripts/snapper-daily
+index 27e7a10..2ee7fff 100755
+--- a/scripts/snapper-daily
++++ b/scripts/snapper-daily
+@@ -9,10 +9,10 @@ export PATH
+
+
+ #
+-# get information from /etc/sysconfig/snapper
++# get information from /etc/conf.d/snapper
+ #
+-if [ -f /etc/sysconfig/snapper ] ; then
+- . /etc/sysconfig/snapper
++if [ -f /etc/conf.d/snapper ] ; then
++ . /etc/conf.d/snapper
+ fi
+
+
+diff --git a/scripts/snapper-hourly b/scripts/snapper-hourly
+index bc6cd4d..1ef49ff 100755
+--- a/scripts/snapper-hourly
++++ b/scripts/snapper-hourly
+@@ -9,10 +9,10 @@ export PATH
+
+
+ #
+-# get information from /etc/sysconfig/snapper
++# get information from /etc/conf.d/snapper
+ #
+-if [ -f /etc/sysconfig/snapper ] ; then
+- . /etc/sysconfig/snapper
++if [ -f /etc/conf.d/snapper ] ; then
++ . /etc/conf.d/snapper
+ fi
+
+
diff --git a/cron-rename.patch b/cron-rename.patch
new file mode 100644
index 000000000000..118f3ccdb80a
--- /dev/null
+++ b/cron-rename.patch
@@ -0,0 +1,14 @@
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 506f74a..407382c 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -17,7 +17,7 @@ endif
+ EXTRA_DIST = snapper-hourly snapper-daily bash-completion.bash $(pam_snapper_SCRIPTS)
+
+ install-data-local:
+- install -D snapper-hourly $(DESTDIR)/etc/cron.hourly/suse.de-snapper
+- install -D snapper-daily $(DESTDIR)/etc/cron.daily/suse.de-snapper
++ install -D snapper-hourly $(DESTDIR)/etc/cron.hourly/snapper
++ install -D snapper-daily $(DESTDIR)/etc/cron.daily/snapper
+ install -D --mode a+r,u+w bash-completion.bash $(DESTDIR)/usr/share/bash-completion/completions/snapper
+
diff --git a/drift-file-path.patch b/drift-file-path.patch
new file mode 100644
index 000000000000..761a0d80f28b
--- /dev/null
+++ b/drift-file-path.patch
@@ -0,0 +1,10 @@
+diff --git a/data/base.txt b/data/base.txt
+index c75fde9..e1d5303 100644
+--- a/data/base.txt
++++ b/data/base.txt
+@@ -2,4 +2,4 @@
+ /etc/mtab
+ /var/lib/logrotate.status
+ /var/lib/misc/random-seed
+-/var/lib/ntp/drift/ntp.drift
++/var/lib/ntp/ntp.drift
diff --git a/usr-paths.patch b/usr-paths.patch
new file mode 100644
index 000000000000..aa865f13584e
--- /dev/null
+++ b/usr-paths.patch
@@ -0,0 +1,12 @@
+diff --git a/data/org.opensuse.Snapper.service b/data/org.opensuse.Snapper.service
+index 39d7333..6c49474 100644
+--- a/data/org.opensuse.Snapper.service
++++ b/data/org.opensuse.Snapper.service
+@@ -1,5 +1,5 @@
+ # DBus service activation config
+ [D-BUS Service]
+ Name=org.opensuse.Snapper
+-Exec=/usr/sbin/snapperd
++Exec=/usr/bin/snapperd
+ User=root
+