summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD38
-rwxr-xr-xsnowflake2
-rw-r--r--snowflake.desktop7
5 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5cbf652738ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = snowflake
+ pkgdesc = Graphical SFTP client and terminal emulator with helpful utilities.
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/subhra74/snowflake
+ arch = any
+ license = GPL3
+ makedepends = java-environment>=11
+ makedepends = maven
+ depends = java-runtime>=11
+ source = snowflake-1.0.3.tar.gz::https://github.com/subhra74/snowflake/archive/v1.0.3.tar.gz
+ source = snowflake
+ source = snowflake.desktop
+ sha256sums = 8259cea965e05db73463eab1872ba75e354b53f87dd0b7f35422d6122c1362d4
+ sha256sums = d688b2ac7cbc88a28d02a108ef82fe6a6dbf6ac66c9aa3745f6869408bfa2b3f
+ sha256sums = 832e38bbf4a7b451b2bf674b294a9bc8299a24a9d7d37b517c1f3fd71ba6f80e
+
+pkgname = snowflake
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6edf65a7667a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.tar
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42869be0b142
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: José Rebelo <joserebelo at outlook dot com>
+
+pkgname=snowflake
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='Graphical SFTP client and terminal emulator with helpful utilities.'
+arch=('any')
+url="https://github.com/subhra74/snowflake"
+license=('GPL3')
+depends=('java-runtime>=11')
+makedepends=('java-environment>=11' 'maven')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/subhra74/snowflake/archive/v${pkgver}.tar.gz"
+ "${pkgname}"
+ "${pkgname}.desktop"
+)
+sha256sums=(
+ '8259cea965e05db73463eab1872ba75e354b53f87dd0b7f35422d6122c1362d4'
+ 'd688b2ac7cbc88a28d02a108ef82fe6a6dbf6ac66c9aa3745f6869408bfa2b3f'
+ '832e38bbf4a7b451b2bf674b294a9bc8299a24a9d7d37b517c1f3fd71ba6f80e'
+)
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ # Current release has http url
+ sed -i 's#http://jcenter#https://jcenter#' pom.xml
+
+ mvn clean install
+}
+
+package() {
+ install -Dm644 "${pkgname}-${pkgver}/target/${pkgname}.jar" "${pkgdir}/opt/${pkgname}/${pkgname}.jar"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -Dm644 "${pkgname}-${pkgver}/src/main/resources/snowflake-logo256.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/snowflake.png"
+}
diff --git a/snowflake b/snowflake
new file mode 100755
index 000000000000..f616057ae064
--- /dev/null
+++ b/snowflake
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -jar /opt/snowflake/snowflake.jar
diff --git a/snowflake.desktop b/snowflake.desktop
new file mode 100644
index 000000000000..c9e14280b9a6
--- /dev/null
+++ b/snowflake.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Snowflake
+Icon=snowflake
+Type=Application
+Exec=snowflake
+Comment=Graphical SFTP client and terminal emulator with helpful utilities
+Categories=Development;