summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD23
-rw-r--r--sfsql.patch12
4 files changed, 28 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f648b18ff785..bcd298571ca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = snowflake-client
pkgdesc = Snowflake Database command line client (snowsql)
- pkgver = 1.1.82
+ pkgver = 1.2.10
pkgrel = 1
epoch = 1
url = http://www.snowflake.net/
arch = x86_64
license = custom: commercial
depends = gcc-libs
- source = snowflake-client-1.1.82.sh::http://s3-us-west-2.amazonaws.com/sfc-snowsql-updates/bootstrap/1.1/linux_x86_64/snowsql-1.1.82-linux_x86_64.bash
- md5sums = e93cc95e21576b63d013e7c2e03e2b35
+ source = snowflake-client-1.2.10.bash::https://sfc-repo.snowflakecomputing.com/snowsql/bootstrap/1.2/linux_x86_64/snowsql-1.2.10-linux_x86_64.bash
+ source = snowflake-client-1.2.10.bash.sig::https://sfc-repo.snowflakecomputing.com/snowsql/bootstrap/1.2/linux_x86_64/snowsql-1.2.10-linux_x86_64.bash.sig
+ sha256sums = 0b7e620efab22df2a22bc80bae81544628a2eb4117a76ec109cfead6e8334c3c
+ sha256sums = f5ecd6ffe307f559c8041c54f57ce4c93e408d6828e573a2411d39d7f7257725
pkgname = snowflake-client
diff --git a/.gitignore b/.gitignore
index 8776c94558f4..0b35524ba62c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,5 @@
-snowflake-client*.sh
+snowflake-client*.bash
+snowflake-client*.bash.sig
+snowflake-client*.pkg.tar.zst
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index ffdc2d2bb23d..541365a019d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,35 @@
# Maintainer: D. Can Celasun <can[at]dcc[dot]im>
+# Co-Maintainer: Ethan Pailes ethan[at]pailes[dot]org
+
+# To be able to verify the gpg signatures run:
+# ```
+# gpg --keyserver hkp://keys.gnupg.net --recv-keys 37C7086698CB005C EC218558EABB25A1
+# printf "trusted-key 37C7086698CB005C\ntrusted-key EC218558EABB25A1\n" >> ~/.gnupg/gpg.conf
+# ```
pkgname=snowflake-client
-pkgver=1.1.82
+pkgver=1.2.10
pkgrel=1
epoch=1
pkgdesc="Snowflake Database command line client (snowsql)"
arch=('x86_64')
url="http://www.snowflake.net/"
license=('custom: commercial')
-depends=(gcc-libs)
-source=(${pkgname}-${pkgver}.sh::http://s3-us-west-2.amazonaws.com/sfc-snowsql-updates/bootstrap/1.1/linux_x86_64/snowsql-${pkgver}-linux_x86_64.bash)
-md5sums=('e93cc95e21576b63d013e7c2e03e2b35')
+depends=('gcc-libs')
+source=(
+ "${pkgname}-${pkgver}.bash::https://sfc-repo.snowflakecomputing.com/snowsql/bootstrap/$(echo ${pkgver} | awk -F. '{print $1 "." $2}')/linux_x86_64/snowsql-${pkgver}-linux_x86_64.bash"
+ "${pkgname}-${pkgver}.bash.sig::https://sfc-repo.snowflakecomputing.com/snowsql/bootstrap/$(echo ${pkgver} | awk -F. '{print $1 "." $2}')/linux_x86_64/snowsql-${pkgver}-linux_x86_64.bash.sig"
+)
+sha256sums=(
+ '0b7e620efab22df2a22bc80bae81544628a2eb4117a76ec109cfead6e8334c3c'
+ 'f5ecd6ffe307f559c8041c54f57ce4c93e408d6828e573a2411d39d7f7257725'
+)
package() {
# Stop Snowflake installer from modifying shell profile
local tmp="$(mktemp)"
- SNOWSQL_DEST="${pkgdir}" SNOWSQL_LOGIN_SHELL="${tmp}" sh "${pkgname}-${pkgver}.sh"
+ SNOWSQL_DEST="${pkgdir}" SNOWSQL_LOGIN_SHELL="${tmp}" sh "${pkgname}-${pkgver}.bash"
install -Dm755 "${pkgdir}/snowsql" "${pkgdir}/usr/bin/snowsql"
rm -f "${pkgdir}/snowsql"
diff --git a/sfsql.patch b/sfsql.patch
deleted file mode 100644
index 92554605e308..000000000000
--- a/sfsql.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur a/client/sfsql b/client/sfsql
---- a/client/sfsql 2015-09-18 22:25:07.000000000 +0300
-+++ b/client/sfsql 2015-09-18 22:31:18.395451951 +0300
-@@ -4,7 +4,7 @@
- # options are ignored if SF_SQL_CONNECT_URL if set
-
- #default values for command line options
--CLIENT_DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
-+CLIENT_DIR="/opt/snowflake-client"
- HENPLUS_DIR="$( cd "${CLIENT_DIR}/henplus" && pwd )"
-
- Usage()