summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4893c8140d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = soapybladerf-git
+ pkgdesc = SoapySDR plugin for BladeRF
+ pkgver = r63.9a0cb72
+ pkgrel = 1
+ epoch = 2
+ url = https://github.com/pothosware/SoapyBladeRF
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = soapysdr
+ depends = bladerf
+ provides = soapybladerf
+ conflicts = soapybladerf
+ source = soapybladerf-git::git+https://github.com/pothosware/SoapyBladeRF.git
+ sha256sums = SKIP
+
+pkgname = soapybladerf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a21e3bd64b9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: karel <karelparlin at gmail dot com>
+
+pkgname=soapybladerf-git
+pkgver=r63.9a0cb72
+pkgrel=1
+epoch=2
+pkgdesc="SoapySDR plugin for BladeRF"
+arch=('any')
+url="https://github.com/pothosware/SoapyBladeRF"
+license=('GPLv3')
+depends=('soapysdr' 'bladerf')
+makedepends=('git')
+provides=('soapybladerf')
+conflicts=('soapybladerf')
+source=(${pkgname}::"git+https://github.com/pothosware/SoapyBladeRF.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make -j4
+}
+
+package() {
+ make -C "${srcdir}/${pkgname}/build" DESTDIR="${pkgdir}" install
+}