summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 28 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be0daaf32fa8..750672a8fd32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = socialfish
pkgdesc = Educational phishing tool and information collector using ngrok
pkgver = 2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/UndeadSec/SocialFish
arch = i686
arch = x86_64
@@ -9,21 +9,20 @@ pkgbase = socialfish
arch = aarch64
license = BSD
makedepends = python-pip
- makedepends = python-setuptools
depends = php
depends = python-requests
- provides = socialfish
- conflicts = socialfish-git
+ depends = python-wget
+ depends = python-huepy
source = https://github.com/UndeadSec/SocialFish/archive/sharkNet.tar.gz
sha256sums = 71bb69585c7cd54b2dbe5af265eecd255854f3741cd89ba7a326db123ab17a7c
source_i686 = https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-386.zip
- sha256sums_i686 = 779c34132db40b700cf14a1d5b9ec55038f5c000c6c9ba20ba0128b91ee612d2
+ sha256sums_i686 = 136673d9f46ecea7cd0d94d617f07d98fce24a99892d3324f9714c9e3df50c0f
source_x86_64 = https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-amd64.zip
- sha256sums_x86_64 = 045ac9f9fc95bdc9ea8113895c3c8f82e99b79350b16306d1af8883a498d8224
+ sha256sums_x86_64 = 1761f150c5e1d210e8148a863441af4bf0f0ae413d205fdb3ce9db4a3454d504
source_armv7h = https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-arm.zip
- sha256sums_armv7h = b94563b5966a852b9ca079781cdfdaea613ae1fe28f7dd19567380ee96ca2bc0
+ sha256sums_armv7h = 0e21e242858be513f70a22a2e5f40e5859275454f7b18d451ec30af4deba2dd2
source_aarch64 = https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-arm64.zip
- sha256sums_aarch64 = b62b3cdaec4b6546a0471a466f9f9516f7bd4ff6b33ab2264824ef18cc8ea62f
+ sha256sums_aarch64 = c5dc3050fbe6f98afaee8878c0d9c85d1c00da8f8dcd6aba067b356cf401b93e
pkgname = socialfish
diff --git a/PKGBUILD b/PKGBUILD
index a234d120d367..cbebc4ea7744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,47 @@
# Maintainer: Kr1ss <kr1ss.x@yandex.com>
+
pkgname=socialfish
+
pkgver=2.0
-pkgrel=2
+pkgrel=3
+
pkgdesc='Educational phishing tool and information collector using ngrok'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
-url="https://github.com/UndeadSec/SocialFish"
+url=https://github.com/UndeadSec/SocialFish
license=('BSD')
-depends=('php' 'python-requests')
-makedepends=('python-pip' 'python-setuptools')
-provides=("$pkgname")
-conflicts=("${pkgname}-git")
+makedepends=('python-pip')
+depends=('php' 'python-requests' 'python-wget' 'python-huepy')
-source=('https://github.com/UndeadSec/SocialFish/archive/sharkNet.tar.gz')
+source=("$url/archive/sharkNet.tar.gz")
source_i686=('https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-386.zip')
source_x86_64=('https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-amd64.zip')
source_armv7h=('https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-arm.zip')
source_aarch64=('https://bin.equinox.io/c/4VmDzA7iaHb/ngrok-stable-linux-arm64.zip')
sha256sums=('71bb69585c7cd54b2dbe5af265eecd255854f3741cd89ba7a326db123ab17a7c')
-sha256sums_i686=('779c34132db40b700cf14a1d5b9ec55038f5c000c6c9ba20ba0128b91ee612d2')
-sha256sums_x86_64=('045ac9f9fc95bdc9ea8113895c3c8f82e99b79350b16306d1af8883a498d8224')
-sha256sums_armv7h=('b94563b5966a852b9ca079781cdfdaea613ae1fe28f7dd19567380ee96ca2bc0')
-sha256sums_aarch64=('b62b3cdaec4b6546a0471a466f9f9516f7bd4ff6b33ab2264824ef18cc8ea62f')
+sha256sums_i686=('136673d9f46ecea7cd0d94d617f07d98fce24a99892d3324f9714c9e3df50c0f')
+sha256sums_x86_64=('1761f150c5e1d210e8148a863441af4bf0f0ae413d205fdb3ce9db4a3454d504')
+sha256sums_armv7h=('0e21e242858be513f70a22a2e5f40e5859275454f7b18d451ec30af4deba2dd2')
+sha256sums_aarch64=('c5dc3050fbe6f98afaee8878c0d9c85d1c00da8f8dcd6aba067b356cf401b93e')
+
package() {
cd "$srcdir/SocialFish-sharkNet"
- pip install --root="$pkgdir" wget==3.2 huepy==0.9.8.1
install -Dm755 SocialFish.py "$pkgdir/usr/lib/$pkgname/SocialFish.py"
cp -r base core "$pkgdir/usr/lib/$pkgname/"
install -m755 ../ngrok "$pkgdir/usr/lib/$pkgname/base/Server/"
install -dm755 "$pkgdir/usr/bin"
- cat >"$pkgdir/usr/bin/socialfish" <<-EOF
+ cat >"$pkgdir/usr/bin/$pkgname" <<-EOF
#!/bin/sh
+
cd /usr/lib/socialfish/
python SocialFish.py
-
EOF
- chmod 755 "$pkgdir/usr/bin/socialfish"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ chmod 755 "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md Images/* -t"$pkgdir/usr/share/doc/$pkgname/"
}
+
+
+# vim: ts=4 sw=4 noet ft=PKGBUILD: