summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
-rw-r--r--sodalite.install21
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..676c35d1f996
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sodalite
+ pkgdesc = Keyboard-driven terminal file navigator and launcher
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = www.github.com/hnicke/sodalite
+ install = sodalite.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = awk
+ depends = python-binaryornot
+ depends = python-npyscreen-git
+ depends = sqlite
+ source = https://github.com/hnicke/$package/archive/$pkgver.tar.gz
+ md5sums = SKIP
+
+pkgname = sodalite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f60ca8fee8a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Heiko Nickerl <dev at heiko-nickerl dot com>
+pkgname="sodalite"
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Keyboard-driven terminal file navigator and launcher"
+arch=('any')
+url="www.github.com/hnicke/sodalite"
+license=('GPL')
+makedepends=('git' 'awk' )
+depends=('python-binaryornot' 'python-npyscreen-git' 'sqlite' )
+source=('https://github.com/hnicke/$package/archive/$pkgver.tar.gz')
+md5sums=('SKIP')
+install=sodalite.install
+
+_gitroot=https://github.com/hnicke/$pkgname.git
+
+package() {
+ cd "${srcdir}/$pkgname"
+ FAKE_ROOT=$pkgdir ./install
+}
diff --git a/sodalite.install b/sodalite.install
new file mode 100644
index 000000000000..027d857f8e22
--- /dev/null
+++ b/sodalite.install
@@ -0,0 +1,21 @@
+# arg 1: the new package version
+post_install() {
+ bold=$(tput bold)
+ normal=$(tput sgr0)
+ echo "
+ ===> ${bold}Sodalite wants to be part of your shell ${normal}(supported: bash, zsh, fish)
+
+ ${bold}bash, zsh:
+
+ ${normal}Add following line to your .bashrc/.zshrc:
+ source /usr/share/sodalite/shell-integration.sh
+
+ ${bold}fish:
+
+ ${normal}If not exists, create function 'fish_user_key_bindings' in your config.fish and insert following line into the function:
+ source /usr/share/sodalite/shell-integration.fish
+
+ "
+}
+
+post_install