summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--ssl_load_error.patch13
3 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4712b1f41220..921d7f157191 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sogo
pkgdesc = groupware server built around OpenGroupware.org (OGo) and the SOPE application server
pkgver = 4.0.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.sogo.nu/
install = sogo.install
arch = x86_64
@@ -28,13 +28,15 @@ pkgbase = sogo
backup = etc/httpd/conf/extra/SOGo.conf
backup = etc/conf.d/sogo
source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-4.0.2.tar.gz
- source = sogo_configure.patch
source = sogo.service
source = sogo.confd
+ source = sogo_configure.patch
+ source = ssl_load_error.patch
sha256sums = 35ef20216ff1758a593bed69d8e8e25d23e982a970bf23a3bb2f856f2e5d2f9f
- sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
sha256sums = 0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c
sha256sums = 8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7
+ sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
+ sha256sums = 55934b0763d809b30ac8b597f5c8be32c9226040c5c8d9eff2bb9cc004072c17
pkgname = sogo
diff --git a/PKGBUILD b/PKGBUILD
index 528d509dfe4f..fb2591a946b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=sogo
pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
pkgver=4.0.2
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="http://www.sogo.nu/"
license=('GPL')
@@ -32,24 +32,25 @@ backup=('etc/sogo/sogo.conf'
'etc/httpd/conf/extra/SOGo.conf'
'etc/conf.d/sogo')
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz"
- "sogo_configure.patch"
"sogo.service"
- "sogo.confd")
+ "sogo.confd"
+ "sogo_configure.patch"
+ "ssl_load_error.patch")
sha256sums=('35ef20216ff1758a593bed69d8e8e25d23e982a970bf23a3bb2f856f2e5d2f9f'
- 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
'0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c'
- '8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7')
+ '8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7'
+ 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
+ '55934b0763d809b30ac8b597f5c8be32c9226040c5c8d9eff2bb9cc004072c17')
prepare() {
cd "$srcdir/SOGo-${pkgver}"
patch configure ../sogo_configure.patch
+ patch -Np1 -i ../ssl_load_error.patch
}
build() {
cd "$srcdir/SOGo-${pkgver}"
./configure --prefix=$(gnustep-config --variable=GNUSTEP_SYSTEM_ROOT) --disable-debug
- # fix ssl error message, this should be harmless
- sed '/SSL_load_error_strings/d' -i UI/MailPartViewers/UIxMailPartSignedViewer.m
make
}
diff --git a/ssl_load_error.patch b/ssl_load_error.patch
new file mode 100644
index 000000000000..c56cce845911
--- /dev/null
+++ b/ssl_load_error.patch
@@ -0,0 +1,13 @@
+--- sogo-SOGo-4.0.2/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-08-24 15:01:47.000000000 +0200
++++ sogo-SOGo-4.0.1/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-07-10 15:51:12.000000000 +0200
+@@ -170,9 +170,8 @@
+ if (err)
+ {
+ ERR_load_crypto_strings();
+- SSL_load_error_strings();
+ sslError = ERR_reason_error_string(err);
+- validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError ? sslError : "(no error information available)"]] retain];
++ validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError]] retain];
+ }
+ }
+