summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD5
-rw-r--r--sogo.install3
-rw-r--r--sogo.service2
3 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d50217023e7..9367a5130622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=('sogo'
'sogo-openchange'
'sogo-activesync')
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.sogo.nu/"
license=('GPL')
@@ -16,7 +16,6 @@ makedepends=('gcc-objc'
'libmemcached'
'sope>=2.3.0')
options=('!strip')
-install=sogo.install
source=(
http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz
sogo_configure.patch
@@ -51,12 +50,14 @@ optdepends=(
'lighttpd: webserver to provide web interface locally'
'funambol: sync mobile devices with sogo contacts, events, tasks via SyncML')
backup=(etc/sogo/sogo.conf etc/httpd/conf/extra/SOGo.conf)
+install=sogo.install
cd "${srcdir}/SOGo-${pkgver}"
make install DESTDIR="${pkgdir}" GNUSTEP_SYSTEM_ADMIN_TOOLS="/usr/bin"
install -D -m 0644 "${srcdir}"/sogo.service "${pkgdir}"/usr/lib/systemd/system/sogo.service
install -D -m 0600 "${srcdir}"/SOGo-${pkgver}/Scripts/sogo.conf "${pkgdir}"/etc/sogo/sogo.conf
install -D -m 0644 "${srcdir}"/SOGo-${pkgver}/Apache/SOGo.conf "${pkgdir}"/etc/httpd/conf/extra/SOGo.conf
+ install -D -m 0644 "${srcdir}"/SOGo-${pkgver}/Scripts/logrotate "${pkgdir}"/etc/logrotate.d/sogo
}
package_sogo-openchange() {
diff --git a/sogo.install b/sogo.install
index 5b6935f25576..78e2b5876ae9 100644
--- a/sogo.install
+++ b/sogo.install
@@ -1,6 +1,7 @@
post_install() {
useradd -r -d /etc/sogo sogo &>/dev/null
- chown -R sogo:sogo /etc/sogo
+ mkdir -p /var/log/sogo
+ chown -R sogo:sogo /etc/sogo /var/log/sogo
}
pre_remove() {
diff --git a/sogo.service b/sogo.service
index 46120bfc997b..a97536d8536b 100644
--- a/sogo.service
+++ b/sogo.service
@@ -5,7 +5,7 @@ After=network.target slapd.service memcached.service postfix.service dovecot.ser
[Service]
User=sogo
RuntimeDirectory=sogo
-ExecStart=/usr/bin/sogod -WOPidFile /var/run/sogo/sogo.pid -WOLogFile "-" -WONoDetach YES
+ExecStart=/usr/bin/sogod -WOPidFile /var/run/sogo/sogo.pid -WONoDetach YES
[Install]
WantedBy=multi-user.target