summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
-rw-r--r--sogo-bugfix_4566.patch24
3 files changed, 10 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 450e1b3712f8..afaa3a42b2be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = sogo
pkgdesc = groupware server built around OpenGroupware.org (OGo) and the SOPE application server
- pkgver = 4.0.2
- pkgrel = 5
+ pkgver = 4.0.4
+ pkgrel = 1
url = http://www.sogo.nu/
install = sogo.install
arch = x86_64
license = GPL
makedepends = gcc-objc
makedepends = gnustep-make
- depends = sope>=4.0.2
+ depends = sope>=4.0.4
depends = gnustep-base
depends = libmemcached
depends = memcached
@@ -27,16 +27,14 @@ pkgbase = sogo
backup = etc/sogo/sogo.conf
backup = etc/httpd/conf/extra/SOGo.conf
backup = etc/conf.d/sogo
- source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-4.0.2.tar.gz
+ source = http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-4.0.4.tar.gz
source = sogo.service
source = sogo.confd
source = sogo_configure.patch
- source = sogo-bugfix_4566.patch
- sha256sums = 35ef20216ff1758a593bed69d8e8e25d23e982a970bf23a3bb2f856f2e5d2f9f
+ sha256sums = 8e3eb750810244c88a4d20127db6987a1cc42845f716964e1d360038c1e26256
sha256sums = 0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c
sha256sums = 8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7
sha256sums = e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1
- sha256sums = 25fe95cd6e55b8f9d4738e652a7a5a1bee3574de80507e2d08518cc4f74c5009
pkgname = sogo
diff --git a/PKGBUILD b/PKGBUILD
index 2e283696eec2..bacca980ef5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Andre Wayand <aur-sogo@awayand.sleepmail.com>
pkgname=sogo
pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
-pkgver=4.0.2
-pkgrel=5
+pkgver=4.0.4
+pkgrel=1
arch=('x86_64')
url="http://www.sogo.nu/"
license=('GPL')
@@ -34,18 +34,15 @@ backup=('etc/sogo/sogo.conf'
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz"
"sogo.service"
"sogo.confd"
- "sogo_configure.patch"
- "sogo-bugfix_4566.patch")
-sha256sums=('35ef20216ff1758a593bed69d8e8e25d23e982a970bf23a3bb2f856f2e5d2f9f'
+ "sogo_configure.patch")
+sha256sums=('8e3eb750810244c88a4d20127db6987a1cc42845f716964e1d360038c1e26256'
'0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c'
'8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7'
- 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
- '25fe95cd6e55b8f9d4738e652a7a5a1bee3574de80507e2d08518cc4f74c5009')
+ 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1')
prepare() {
cd "$srcdir/SOGo-${pkgver}"
patch configure ../sogo_configure.patch
- patch -Np1 -i ../sogo-bugfix_4566.patch
}
build() {
diff --git a/sogo-bugfix_4566.patch b/sogo-bugfix_4566.patch
deleted file mode 100644
index d699d9fe9159..000000000000
--- a/sogo-bugfix_4566.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naurp SOGo-4.0.2-orig/UI/MailPartViewers/UIxMailPartSignedViewer.m SOGo-4.0.2/UI/MailPartViewers/UIxMailPartSignedViewer.m
---- SOGo-4.0.2-orig/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-10-10 23:32:06.753085278 -0500
-+++ SOGo-4.0.2/UI/MailPartViewers/UIxMailPartSignedViewer.m 2018-10-10 23:33:04.864737333 -0500
-@@ -169,10 +169,20 @@
-
- if (err)
- {
-+# ifdef HAVE_GNUTLS
- ERR_load_crypto_strings();
- SSL_load_error_strings();
- sslError = ERR_reason_error_string(err);
- validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError ? sslError : "(no error information available)"]] retain];
-+#elseif (OPENSSL_VERSION_NUMBER < 0x10100000L)
-+ ERR_load_crypto_strings();
-+ SSL_load_error_strings();
-+ sslError = ERR_reason_error_string(err);
-+ validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError]] retain];
-+# else
-+ validationMessage = [[self labelForKey: [NSString stringWithUTF8String: sslError]] retain];
-+#endif /* HAVE_GNUTLS */
-+
- }
- }
-