summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91ccc7223aa1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = solarized-colors-iconpack-git
+ pkgdesc = A set of solarized-colored icons
+ pkgver = 1.0.r112.g623ad87261
+ pkgrel = 1
+ url = https://www.gnome-look.org/p/1309239/
+ arch = any
+ license = GPL
+ makedepends = git
+ source = git+https://github.com/rtlewis88/rtl88-Themes.git#branch=Solarized-Colors-Iconpack
+ sha256sums = SKIP
+
+pkgname = solarized-colors-iconpack-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5488476e766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jouni Rinne <l33tmmx swirlything gmail dot com>
+pkgname=solarized-colors-iconpack-git
+pkgver=1.0.r112.g623ad87261
+pkgrel=1
+pkgdesc="A set of solarized-colored icons"
+arch=('any')
+url="https://www.gnome-look.org/p/1309239/"
+license=('GPL')
+makedepends=('git')
+source=("git+https://github.com/rtlewis88/rtl88-Themes.git#branch=Solarized-Colors-Iconpack")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/rtl88-Themes
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd ${srcdir}/rtl88-Themes
+ mkdir -p ${pkgdir}/usr/share/doc/solarized-colors-iconpack
+ cp README.md ${pkgdir}/usr/share/doc/solarized-colors-iconpack/
+ mkdir -p ${pkgdir}/usr/share/icons
+ cp -R Solarized* ${pkgdir}/usr/share/icons/
+}