summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD61
2 files changed, 50 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d27ab4396ab..018f6581af31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,28 @@
pkgbase = solarus
- pkgdesc = An open-source Zelda-like 2D game engine used by the games zsxd and zsdx.
- pkgver = 1.5.3
- pkgrel = 2
- url = http://www.solarus-engine.org/
+ pkgdesc = A lightweight, free and open-source game engine for Action-RPGs
+ pkgver = 1.6.5
+ pkgrel = 1
+ url = http://www.solarus-games.org/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
makedepends = cmake
- makedepends = zip
- depends = luajit
- depends = sdl2_image
- depends = sdl2_ttf
- depends = physfs
- depends = openal
+ depends = glm
+ depends = hicolor-icon-theme
+ depends = libmodplug>=0.8.8.4
depends = libvorbis
- depends = libmodplug
- depends = qt5-tools
+ depends = luajit>=2.0
+ depends = openal
+ depends = physfs
depends = qt5-base
- optdepends = zsxd
- optdepends = zsdx
- optdepends = zelda-roth-se
- provides = solarus-engine
- conflicts = zsdxdemo-en
- conflicts = zsdxdemo-de
- conflicts = zsdxdemo-fr
+ depends = qt5-tools
+ depends = sdl2>=2.0.6
+ depends = sdl2_image
+ depends = sdl2_ttf
conflicts = solarus-git
- replaces = zsdxdemo-en
- replaces = zsdxdemo-de
- replaces = zsdxdemo-fr
- replaces = solarus-git
- source = http://solarus-games.org/downloads/solarus/solarus-1.5.3-src.tar.gz
- md5sums = 24e0e889940472575a2e81a7dbdcbdbb
+ conflicts = solarus-run
+ source = https://gitlab.com/solarus-games/solarus/-/archive/v1.6.5/solarus-v1.6.5.tar.gz
+ b2sums = 96a67c7210c70d23d3fa08e24ee2c4cfbeb6e95dce7236ab860695bf4fc57aaa5d54b02e25ad2f10dfc498cc836bf83753d99cbeca1ff7bf496f7d589accbbf5
pkgname = solarus
diff --git a/PKGBUILD b/PKGBUILD
index dd6fe1a17237..7a449cc059e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,44 @@
-# Maintainer: BenObiWan <benobiwan @t gmail dot com>
+# Maintainer: MCMic <come@chilliet.eu>
+# Contributor: MCMic <come@chilliet.eu>
# Contributor: Sam101 <zoetrem @t gmail dot com>
# Contributor: BenObiWan <benobiwan @t gmail dot com>
# Contributor: Huulivoide
# Contributor: Fernando Carmona Varo <ferkiwi @t gmail dot com>
+# Contributor: Franck Stauffer <franck.stauffer@monaco.mc>
+
pkgname=solarus
-pkgver=1.5.3
-pkgrel=2
-epoch=
-pkgdesc="An open-source Zelda-like 2D game engine used by the games zsxd and zsdx."
+pkgver=1.6.5
+pkgrel=1
+pkgdesc="A lightweight, free and open-source game engine for Action-RPGs"
arch=('i686' 'x86_64')
-url="http://www.solarus-engine.org/"
-license=('GPL')
-groups=()
-depends=('luajit' 'sdl2_image' 'sdl2_ttf' 'physfs' 'openal' 'libvorbis' 'libmodplug' 'qt5-tools' 'qt5-base')
-makedepends=('cmake' 'zip')
-checkdepends=()
-optdepends=('zsxd' 'zsdx' 'zelda-roth-se')
-provides=('solarus-engine')
-conflicts=('zsdxdemo-en' 'zsdxdemo-de' 'zsdxdemo-fr' 'solarus-git')
-replaces=('zsdxdemo-en' 'zsdxdemo-de' 'zsdxdemo-fr' 'solarus-git')
-backup=()
-options=()
-install=
-changelog=
-source=(http://solarus-games.org/downloads/$pkgname/$pkgname-$pkgver-src.tar.gz)
-noextract=()
-md5sums=('24e0e889940472575a2e81a7dbdcbdbb')
+url="http://www.solarus-games.org/"
+license=('GPL3')
+depends=('glm'
+ 'hicolor-icon-theme'
+ 'libmodplug>=0.8.8.4'
+ 'libvorbis'
+ 'luajit>=2.0'
+ 'openal'
+ 'physfs'
+ 'qt5-base'
+ 'qt5-tools'
+ 'sdl2>=2.0.6'
+ 'sdl2_image'
+ 'sdl2_ttf')
+makedepends=('cmake')
+conflicts=('solarus-git' 'solarus-run')
+source=("https://gitlab.com/solarus-games/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+b2sums=('96a67c7210c70d23d3fa08e24ee2c4cfbeb6e95dce7236ab860695bf4fc57aaa5d54b02e25ad2f10dfc498cc836bf83753d99cbeca1ff7bf496f7d589accbbf5')
+
+prepare() {
+ cd "$pkgname-v$pkgver"
+ cmake -Wno-dev -DSOLARUS_TESTS=OFF -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=Release .
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- cmake -D CMAKE_INSTALL_PREFIX="/usr" -D CMAKE_BUILD_TYPE=Release -D DEFAULT_QUEST=/usr/share/solarus/zsdx .
- make
+ make -C "$pkgname-v$pkgver" ${MAKEFLAGS}
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}/" PREFIX="/usr" install
+ make -C "$pkgname-v$pkgver" DESTDIR="${pkgdir}/" install
}
-