summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD17
2 files changed, 23 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdfc817d2e16..17f5feaea2bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,29 @@
pkgbase = solid-git
pkgdesc = Hardware integration and detection
- pkgver = 5.240.0_r866.gb865f92
+ pkgver = 6.1.0_r1000.g45b1cc23
pkgrel = 1
url = https://community.kde.org/Frameworks
arch = x86_64
groups = kf6
license = LGPL
- makedepends = extra-cmake-modules-git
- makedepends = git
- makedepends = qt6-tools
makedepends = doxygen
- depends = qt6-declarative
+ makedepends = extra-cmake-modules
+ makedepends = qt6-declarative
+ makedepends = qt6-doc
+ makedepends = qt6-tools
+ depends = gcc-libs
+ depends = glibc
+ depends = libimobiledevice
+ depends = libplist
depends = media-player-info
+ depends = qt6-base
+ depends = systemd-libs
depends = udisks2
- depends = upower-git
+ depends = upower
+ depends = util-linux-libs
provides = solid
conflicts = solid
- source = git+https://github.com/KDE/solid.git
+ source = git+https://invent.kde.org/frameworks/solid.git
md5sums = SKIP
pkgname = solid-git
diff --git a/PKGBUILD b/PKGBUILD
index d044605cb611..e43eed2533c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
-# Maintainer: zan <zan@420blaze.it>
-# Contributor Andrea Scarpino <andrea@archlinux.org>
+# Maintainer: Rustmilian <Rustmilian@proton.me>
pkgname=solid-git
-pkgver=5.240.0_r866.gb865f92
+pkgver=6.1.0_r1000.g45b1cc23
pkgrel=1
pkgdesc='Hardware integration and detection'
arch=(x86_64)
url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(qt6-declarative media-player-info udisks2 upower-git)
-makedepends=(extra-cmake-modules-git git qt6-tools doxygen)
+depends=('gcc-libs' 'glibc' 'libimobiledevice' 'libplist' 'media-player-info' 'qt6-base' 'systemd-libs' 'udisks2' 'upower' 'util-linux-libs')
+makedepends=('doxygen' 'extra-cmake-modules' 'qt6-declarative' 'qt6-doc' 'qt6-tools')
groups=(kf6)
conflicts=(solid)
provides=(solid)
-source=("git+https://github.com/KDE/${pkgname%-git}.git")
+source=("git+https://invent.kde.org/frameworks/${pkgname%-git}.git")
md5sums=('SKIP')
pkgver() {
@@ -24,9 +23,11 @@ pkgver() {
build() {
cmake -B build -S ${pkgname%-git} \
- -DQT_MAJOR_VERSION=6 \
-DBUILD_TESTING=OFF \
- -DBUILD_QCH=ON
+ -DBUILD_QCH=ON \
+ -DWITH_NEW_POWER_ASYNC_API=ON \
+ -DWITH_NEW_POWER_ASYNC_FREEDESKTOP=ON \
+ -DWITH_NEW_SOLID_JOB=ON # https://bugs.archlinux.org/task/64093
cmake --build build
}