summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6ada6237019..e0dba34bd2e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Oct 9 20:47:35 UTC 2016
+# Thu Oct 20 20:53:09 UTC 2016
pkgbase = solidity-git
pkgdesc = The Solidity Contract-Oriented Programming Language (Including solc, lllc; from latest unstable git version)
- pkgver = 0.4.3.git.8572664
+ pkgver = 0.4.3.git.20161020.008c411
pkgrel = 1
url = https://github.com/ethereum/solidity
arch = i686
@@ -15,12 +15,9 @@ pkgbase = solidity-git
makedepends = gcc
makedepends = gcc-libs
makedepends = libtool
- makedepends = yasm
makedepends = git
depends = boost
depends = boost-libs
- depends = crypto++
- depends = jsoncpp
depends = glibc
provides = lll
provides = lllc
diff --git a/PKGBUILD b/PKGBUILD
index 4981a52cff0f..fda9dc111331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: Afri 5chdn <aur@cach.co>
+# Available from AUR: https://aur.archlinux.org/packages/solidity-git/
pkgname=solidity-git
-pkgver=0.4.3.git.8572664
+pkgver=0.4.3.git.20161020.008c411
pkgrel=1
pkgdesc="The Solidity Contract-Oriented Programming Language (Including solc, lllc; from latest unstable git version)"
arch=('i686' 'x86_64')
depends=(
'boost'
'boost-libs'
- 'crypto++'
- 'jsoncpp'
'glibc'
)
makedepends=(
@@ -19,7 +18,6 @@ makedepends=(
'gcc'
'gcc-libs'
'libtool'
- 'yasm'
'git'
)
groups=('ethereum')
@@ -40,7 +38,7 @@ provides=(
pkgver() {
cd ${pkgname%-git}
- echo "`grep -m1 "PROJECT\_VERSION" CMakeLists.txt | tr -cd '[[:digit:]].'`.git.`git log --pretty=format:%h -n 1`"
+ echo "`grep -m1 "PROJECT\_VERSION" CMakeLists.txt | tr -cd '[[:digit:]].'`.git.`date +%Y%m%d`.`git log --pretty=format:%h -n 1`"
}
build() {