summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83b2f62975f2..0f86ca79ddd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = solo2-cli
pkgdesc = Solo 2 CLI
- pkgver = 0.0.6
+ pkgver = 0.0.7
pkgrel = 1
url = https://github.com/solokeys/solo2-cli
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = solo2-cli
makedepends = git
makedepends = systemd
depends = systemd-libs
- conflicts = solo2-cli-git
- source = solo2-cli-0.0.6.tar.gz::https://github.com/solokeys/solo2-cli/archive/refs/tags/v0.0.6.tar.gz
+ depends = ccid
+ source = solo2-cli.tar.gz::https://github.com/solokeys/solo2-cli/archive/refs/tags/v0.0.7.tar.gz
sha256sums = 083014e217779f190e49e4839ae99781c1559690a3ee5d96cbdcb1489e663049
pkgname = solo2-cli
diff --git a/PKGBUILD b/PKGBUILD
index 0d43954088c0..0a64856bf79c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Nicolas Stalder <n+archlinux@stalder.io>
+# Helpful suggestions by Foxboron
pkgname=solo2-cli
pkgver=0.0.7
pkgrel=1
@@ -10,7 +11,6 @@ license=(Apache MIT)
depends=(systemd-libs ccid)
# note we do not need Arch `hidapi` package here, it's a git submodule of Rust hidapi
makedepends=(cargo git systemd)
-conflicts=(solo2-cli-git)
source=(
"$pkgname.tar.gz::https://github.com/solokeys/solo2-cli/archive/refs/tags/v${pkgver}.tar.gz"
)
@@ -20,14 +20,14 @@ sha256sums=(
build() {
cd "${pkgname}-${pkgver}"
- cargo build --release --frozen
+ cargo build --release --frozen --all-features
}
check() {
cd "${pkgname}-${pkgver}"
# make sure shared libs work
target/release/solo2 --version
- cargo test --release
+ cargo test --release --all-features
}
package() {
@@ -36,9 +36,9 @@ package() {
install -Dm644 LICENSE-MIT "$pkgdir/usr/share/licenses/$pkgnamefull/LICENSE-MIT"
# completions
- install -Dm644 target/release/_solo2 -t $pkgdir/usr/share/zsh/site-functions
- install -Dm644 target/release/solo2.bash $pkgdir/usr/share/bash-completion/completions/solo2
+ install -Dm644 target/release/_solo2 -t "$pkgdir/usr/share/zsh/site-functions"
+ install -Dm644 target/release/solo2.bash "$pkgdir/usr/share/bash-completion/completions/solo2"
# udev rule
- install -Dm644 70-solo2.rules -t $pkgdir/usr/lib/udev/rules.d
+ install -Dm644 70-solo2.rules -t "$pkgdir/usr/lib/udev/rules.d"
}