summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Mono-Set-process-name.patch54
-rwxr-xr-xPKGBUILD11
3 files changed, 5 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7853c775c861..64b37e0f4d73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 15 12:38:53 UTC 2016
+# Mon Jan 30 00:20:18 UTC 2017
pkgbase = sonarr-git
pkgdesc = Automated TV series manager and downloader - git branch develop
- pkgver = 2.0.0.r6923.713e109
+ pkgver = 2.0.0.r7071.ef044f1ff
pkgrel = 1
url = https://sonarr.tv
install = sonarr.install
@@ -21,11 +21,9 @@ pkgbase = sonarr-git
source = git://github.com/Sonarr/Sonarr.git#branch=develop
source = sonarr.sh
source = sonarr.service
- source = 0001-Mono-Set-process-name.patch
sha256sums = SKIP
sha256sums = d594c4d5ad3c1b196a00cb9f005d4917ad4d8bb2ebf501010e8be7f349b3caa6
sha256sums = 1ebf903e6199dae6032c7839b00ed20566404daf87cb307ffc9ee8539722a845
- sha256sums = 28ed9a1aa71d0d255c18e2ca17c52b845f69c19e3d2653607cff9a7f478931e1
pkgname = sonarr-git
diff --git a/0001-Mono-Set-process-name.patch b/0001-Mono-Set-process-name.patch
deleted file mode 100644
index fea6bac6f6e4..000000000000
--- a/0001-Mono-Set-process-name.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From e18adba54c6e04c6960faa3904814e9d065fb2ab Mon Sep 17 00:00:00 2001
-From: Lars <larsjohnsen@gmail.com>
-Date: Thu, 3 Sep 2015 14:07:01 +0200
-Subject: [PATCH] Mono: Set process name
-
----
- .../EnvironmentInfo/MonoRuntimeProvider.cs | 23 ++++++++++++++++++++++
- 1 file changed, 23 insertions(+)
-
-diff --git a/src/NzbDrone.Mono/EnvironmentInfo/MonoRuntimeProvider.cs b/src/NzbDrone.Mono/EnvironmentInfo/MonoRuntimeProvider.cs
-index b9884df..f881923 100644
---- a/src/NzbDrone.Mono/EnvironmentInfo/MonoRuntimeProvider.cs
-+++ b/src/NzbDrone.Mono/EnvironmentInfo/MonoRuntimeProvider.cs
-@@ -1,7 +1,10 @@
- using System;
- using System.Reflection;
-+using System.Text;
-+using System.Runtime.InteropServices;
- using NLog;
- using NzbDrone.Common.EnvironmentInfo;
-+using Mono.Unix.Native;
-
- namespace NzbDrone.Mono.EnvironmentInfo
- {
-@@ -13,6 +16,26 @@ public MonoRuntimeProvider(Common.IServiceProvider serviceProvider, Logger logge
- :base(serviceProvider, logger)
- {
- _logger = logger;
-+ unixSetProcessName("sonarr");
-+ }
-+
-+ [DllImport ("libc")] //Linux
-+ private static extern int prctl (int option, byte [] arg2, IntPtr arg3, IntPtr arg4, IntPtr arg5);
-+
-+ public void unixSetProcessName (string name)
-+ {
-+ try {
-+ var success = 0 == prctl(15 /* PR_SET_NAME */, Encoding.ASCII.GetBytes (name + "\0"), IntPtr.Zero, IntPtr.Zero, IntPtr.Zero);
-+ if (!success)
-+ {
-+ var error = Stdlib.GetLastError();
-+ throw new InvalidOperationException("prtctl call error: " + error);
-+ }
-+ }
-+ catch (Exception ex)
-+ {
-+ _logger.ErrorException("Could not set process name, error: " + ex.Message, ex);
-+ }
- }
-
- public override string RuntimeVersion
---
-2.10.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 61ad8f1bc62b..4bda446b36f2 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _gitver="2.0.0"
_gitbranch="develop"
pkgname="sonarr-git"
-pkgver=2.0.0.r6923.713e109
+pkgver=2.0.0.r7071.ef044f1ff
pkgrel=1
pkgdesc="Automated TV series manager and downloader - git branch ${_gitbranch}"
arch=(any)
@@ -27,12 +27,10 @@ install='sonarr.install'
changelog=
source=("git://github.com/Sonarr/Sonarr.git#branch=${_gitbranch}"
"sonarr.sh"
- "sonarr.service"
- "0001-Mono-Set-process-name.patch")
+ "sonarr.service")
sha256sums=('SKIP'
'd594c4d5ad3c1b196a00cb9f005d4917ad4d8bb2ebf501010e8be7f349b3caa6'
- '1ebf903e6199dae6032c7839b00ed20566404daf87cb307ffc9ee8539722a845'
- '28ed9a1aa71d0d255c18e2ca17c52b845f69c19e3d2653607cff9a7f478931e1')
+ '1ebf903e6199dae6032c7839b00ed20566404daf87cb307ffc9ee8539722a845')
pkgver() {
@@ -47,9 +45,6 @@ prepare() {
# Install necessary nodejs libraries
npm install
- msg2 "Patching Mono-Set-process-name"
- git apply --ignore-whitespace "${srcdir}/0001-Mono-Set-process-name.patch"
-
git submodule update --init
}