summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD25
-rw-r--r--sonic2013.install18
3 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa63dbda5060..f80fd119be86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sonic2013-git
pkgdesc = A full decompilation of Sonic 1 & 2 (2013).
- pkgver = r581.7f52eb9
+ pkgver = r773.c8f442c
pkgrel = 1
url = https://github.com/Rubberduckycooly/Sonic-1-2-2013-Decompilation
install = sonic2013.install
@@ -14,7 +14,7 @@ pkgbase = sonic2013-git
depends = tinyxml2
provides = sonic2013
source = git+https://github.com/Rubberduckycooly/Sonic-1-2-2013-Decompilation.git
- source = git+https://github.com/nothings/stb.git
+ source = git+https://github.com/leethomason/tinyxml2.git
source = template-launcher
source = template.desktop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f4d3451840b1..f68d4c15b27c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
# Maintainer: Lucas Melo <luluco250 at gmail dot com>
pkgname=sonic2013-git
-pkgver=r581.7f52eb9
+pkgver=r773.c8f442c
pkgrel=1
pkgdesc='A full decompilation of Sonic 1 & 2 (2013).'
arch=('any')
url='https://github.com/Rubberduckycooly/Sonic-1-2-2013-Decompilation'
license=('custom:RSDKv3/4 Decompilation Source Code License v1')
makedepends=('git')
-depends=('sdl2' 'libogg' 'libvorbis' 'asio' 'tinyxml2')
+depends=(
+ 'sdl2'
+ 'libogg'
+ 'libvorbis'
+ 'asio'
+ 'tinyxml2'
+)
provides=(sonic2013)
source=(
"git+${url}.git"
- 'git+https://github.com/nothings/stb.git'
+ 'git+https://github.com/leethomason/tinyxml2.git'
'template-launcher'
- 'template.desktop')
+ 'template.desktop'
+)
sha256sums=(
'SKIP'
'SKIP'
'53ea1912492a15bf54f6dba1859aaf0f9ca0c01615f021faa8a3c67449b1fd55'
- '55df140227c69094fac5ee7dd1b8a8e8beef9abe4072dee00e1688a0b9966353')
+ '55df140227c69094fac5ee7dd1b8a8e8beef9abe4072dee00e1688a0b9966353'
+)
install=sonic2013.install
pkgver() {
@@ -28,12 +36,15 @@ pkgver() {
}
prepare() {
- ln -sfn "$srcdir/stb" "$srcdir/Sonic-1-2-2013-Decompilation/dependencies/all/stb-image"
+ cd "$srcdir/Sonic-1-2-2013-Decompilation"
+ git submodule init
+ git config submodule.dependencies/all/tinyxml2.url "$srcdir/tinyxml2"
+ git submodule update
}
build() {
cd "$srcdir/Sonic-1-2-2013-Decompilation"
- make ${MAKEFLAGS:--j$(nproc)}
+ make ${MAKEFLAGS:-CXXFLAGS=-O2 -j$(nproc)}
cd "$srcdir"
for i in 1 2; do
diff --git a/sonic2013.install b/sonic2013.install
index 90c984b36d48..ce6af52c030a 100644
--- a/sonic2013.install
+++ b/sonic2013.install
@@ -1,16 +1,6 @@
post_install() {
- echo "Use 'sonic1-launcher' and 'sonic2-launcher' to automatically run " \
-"'RSDKv4' from 'sonic1' and 'sonic2' folders created in your " \
-"\$XDG_DATA_HOME or '~/.local/share' folder."
- echo "Alternatively, you may simply run 'RSDKv4' directly from any " \
-"folder containing compatible data files."
-}
-
-post_upgrade() {
- old_rev="$(echo $2 | sed -nr 's/^r([0-9]+)\..*/\1/p')"
-
- if (( $old_rev < 293 )); then
- echo "Heads up, 'sonic2013' has been renamed to 'RSDKv4'!" \
-"Launchers are not affected."
- fi
+ echo "Use <sonic1|sonic2>-launcher to make RSDKv4 look for data in "\
+"<\$XDG_DATA_HOME|~/.local/share>/<sonic1|sonic2>"
+ echo "Alternatively, running RSDKv4 directly will have it look in "\
+"<\$XDG_DATA_HOME|~/.local/share>/RSDKv4"
}