summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 835b435dc723..82a0d00f870d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = sotw-dev
pkgdesc = Shadow Of The Wyrm by Julian Day - Development branch.
pkgver = development
- pkgrel = 5
+ pkgrel = 6
url = http://www.shadowofthewyrm.org/
arch = x86_64
license = MIT
makedepends = premake
makedepends = git
+ depends = sdl2
+ depends = sdl2_image
depends = xerces-c
depends = zlib
depends = ncurses
diff --git a/PKGBUILD b/PKGBUILD
index 1fbf9599d43b..a01b70c0bb5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
#Maintainer: Larzid <juanitocampamocha@gmail.com>
pkgname=sotw-dev
pkgver=development
-pkgrel=5
+pkgrel=6
epoch=
pkgdesc="Shadow Of The Wyrm by Julian Day - Development branch."
arch=('x86_64')
url="http://www.shadowofthewyrm.org/"
license=('MIT')
groups=()
-depends=('xerces-c' 'zlib' 'ncurses' 'lua51' 'boost' 'gtest')
+depends=('sdl2' 'sdl2_image' 'xerces-c' 'zlib' 'ncurses' 'lua51' 'boost' 'gtest')
makedepends=('premake' 'git')
checkdepends=()
provides=(sotw)
@@ -31,25 +31,21 @@ build() {
}
package() {
- echo "cd /usr/share/shadow-of-the-wyrm/sotw" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
- echo "./sotw" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "cd /usr/share/shadow-of-the-wyrm" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "./ShadowOfTheWyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
chmod +x ${srcdir}/shadow-of-the-wyrm/sotw.sh
install -D -m644 ${srcdir}/shadow-of-the-wyrm/LICENSE "${pkgdir}/usr/share/licenses/shadow-of-the-wyrm/LICENSE"
- install -d -m777 ${srcdir}/shadow-of-the-wyrm/sotw "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/howdoi.txt "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/howdoi.txt"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/README.md "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/README.md"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_blank.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_blank.ini"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_en.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/shadowofthewyrmtext_en.ini"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/sotw "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/sotw"
- install -D ${srcdir}/shadow-of-the-wyrm/sotw/swyrm.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/swyrm.ini"
+ install -d -m777 ${srcdir}/shadow-of-the-wyrm "${pkgdir}/usr/share/shadow-of-the-wyrm"
install -D ${srcdir}/shadow-of-the-wyrm/ShadowOfTheWyrm "${pkgdir}/usr/share/shadow-of-the-wyrm/ShadowOfTheWyrm"
install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini"
install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini"
install -D ${srcdir}/shadow-of-the-wyrm/swyrm.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/swyrm.ini"
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/data ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/data
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/docs ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/docs
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/licenses ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/licenses
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/scripts ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/scripts
- cp -R ${srcdir}/shadow-of-the-wyrm/sotw/texts ${pkgdir}/usr/share/shadow-of-the-wyrm/sotw/texts
- install -D ${srcdir}/shadow-of-the-wyrm/sotw.sh ${pkgdir}/usr/bin/sotw
+ install -D ${srcdir}/shadow-of-the-wyrm/version_info.txt "${pkgdir}/usr/share/shadow-of-the-wyrm/version_info.txt"
+ cp -R ${srcdir}/shadow-of-the-wyrm/assets ${pkgdir}/usr/share/shadow-of-the-wyrm/assets
+ cp -R ${srcdir}/shadow-of-the-wyrm/data ${pkgdir}/usr/share/shadow-of-the-wyrm/data
+ cp -R ${srcdir}/shadow-of-the-wyrm/docs ${pkgdir}/usr/share/shadow-of-the-wyrm/docs
+ cp -R ${srcdir}/shadow-of-the-wyrm/licenses ${pkgdir}/usr/share/shadow-of-the-wyrm/licenses
+ cp -R ${srcdir}/shadow-of-the-wyrm/scripts ${pkgdir}/usr/share/shadow-of-the-wyrm/scripts
+ cp -R ${srcdir}/shadow-of-the-wyrm/texts ${pkgdir}/usr/share/shadow-of-the-wyrm/texts
+ install -D ${srcdir}/shadow-of-the-wyrm/sotw.sh ${pkgdir}/usr/bin/sotw
}