summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 21 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44e75df2f88d..386172d954e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Feb 14 17:23:39 UTC 2016
+# Thu Sep 8 16:10:03 UTC 2016
pkgbase = soulseekqt
pkgdesc = A desktop client for the Soulseek peer-to-peer file sharing network
pkgver = 20160117
@@ -8,9 +8,17 @@ pkgbase = soulseekqt
arch = i686
arch = x86_64
license = custom
- source = https://dl.dropboxusercontent.com/u/7226803/SoulseekQt-2016-1-17-32bit.tgz
+ depends = libxext
+ depends = fontconfig
+ depends = libxrender
source = soulseekqt.desktop
source = soulseekqt.png
+ md5sums = 810a4200a3c8568257b66b6bdea5c29c
+ md5sums = 256ec24f7ad2d39ac8da0f1c03d3cafe
+ source_i686 = https://dl.dropboxusercontent.com/u/7226803/SoulseekQt-2016-1-17-32bit.tgz
+ md5sums_i686 = 906d99b15ed02d0d66981fffeeea1218
+ source_x86_64 = https://dl.dropboxusercontent.com/u/7226803/SoulseekQt-2016-1-17-64bit.tgz
+ md5sums_x86_64 = c843e748a129e4ad9461280aeb2b957a
pkgname = soulseekqt
diff --git a/PKGBUILD b/PKGBUILD
index 2f8dc6b43e8c..83f64278cd51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,38 +6,25 @@
pkgname=soulseekqt
pkgver=20160117
_pkgver=2016-1-17
-
-if [[ "$CARCH" == 'x86_64' ]] ; then
- _pkgver=$_pkgver-64bit
-else
- _pkgver=$_pkgver-32bit
-fi
-
pkgrel=2
pkgdesc="A desktop client for the Soulseek peer-to-peer file sharing network"
arch=('i686' 'x86_64')
url="http://www.soulseekqt.net/news/"
license=('custom')
-
-if [[ "$CARCH" == 'i686' ]] ; then
- depends=( 'libxext' 'fontconfig' 'libxrender' )
- md5sums=( '906d99b15ed02d0d66981fffeeea1218'
- '810a4200a3c8568257b66b6bdea5c29c'
- '256ec24f7ad2d39ac8da0f1c03d3cafe' )
-elif [[ "$CARCH" == 'x86_64' ]] ; then
- depends=( 'libxext' 'fontconfig' 'libxrender' )
- md5sums=( 'c843e748a129e4ad9461280aeb2b957a'
- '810a4200a3c8568257b66b6bdea5c29c'
- '256ec24f7ad2d39ac8da0f1c03d3cafe' )
-fi
-
-source=( "https://dl.dropboxusercontent.com/u/7226803/SoulseekQt-$_pkgver.tgz"
- $pkgname.desktop
- $pkgname.png )
+depends=( 'libxext' 'fontconfig' 'libxrender' )
+source=($pkgname.desktop
+ $pkgname.png )
+source_i686=("https://dl.dropboxusercontent.com/u/7226803/SoulseekQt-$_pkgver-32bit.tgz")
+source_x86_64=("https://dl.dropboxusercontent.com/u/7226803/SoulseekQt-$_pkgver-64bit.tgz")
package() {
- install -vDm755 "$srcdir/SoulseekQt-$_pkgver" "$pkgdir/usr/bin/$pkgname"
+ rm $srcdir/*.tgz
+ install -vDm755 $srcdir/SoulseekQt-$_pkgver* "$pkgdir/usr/bin/$pkgname"
install -vDm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
install -vDm644 "$srcdir/$pkgname.png" "$pkgdir/usr/share/pixmaps/soulseek.png"
}
+md5sums=('810a4200a3c8568257b66b6bdea5c29c'
+ '256ec24f7ad2d39ac8da0f1c03d3cafe')
+md5sums_i686=('906d99b15ed02d0d66981fffeeea1218')
+md5sums_x86_64=('c843e748a129e4ad9461280aeb2b957a')