summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fb5c5564637
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Jun 23 15:30:02 UTC 2017
+pkgbase = sound-daemon-phonepi
+ pkgdesc = Sound control daemon for PhonePi project
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/PhonePi
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL2
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-tools
+ source = git://github.com/PhonePi/phonepi.git
+ sha256sums = SKIP
+
+pkgname = sound-daemon-phonepi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca3474811c61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=sound-daemon-phonepi
+pkgver=1
+pkgrel=1
+pkgdesc="Sound control daemon for PhonePi project"
+url="https://github.com/PhonePi"
+arch=("i686" "x86_64" "armv6h")
+license=("GPL2")
+makedepends=("git")
+depends=("qt5-base" "qt5-tools")
+source=(git://github.com/PhonePi/phonepi.git)
+sha256sums=("SKIP")
+
+build() {
+ cd "$srcdir/phonepi/src/btn_sound"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/phonepi/src/btn_sound"
+ make DESTDIR=$pkgdir install
+ install -Dm755 "./btn_sound.service" "$pkgdir/usr/lib/systemd/system/btn_sound.service"
+}