summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
-rw-r--r--soundclip-launcher2
-rw-r--r--soundclip.desktop11
5 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a84ad9730287
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = soundclip-git
+ pkgdesc = Theatre Sound Cue Management
+ pkgver = 0.1.3841f84
+ pkgrel = 1
+ url = https://github.com/soundclip/soundclip
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = maven>=3
+ makedepends = java-environment-jdk>=8
+ depends = java-runtime>=8
+ depends = gstreamer
+ source = soundclip::git+https://github.com/soundclip/soundclip.git
+ source = soundclip-launcher
+ source = soundclip.desktop
+ sha256sums = SKIP
+ sha256sums = 26e71d5998b5341a670d9eea0be21c14a90546a9052e3a606d52bcafbe210dfe
+ sha256sums = ed8a89f67ee4b0c0fe831da35d2fd0d3731f951c723068949705aed6d9ffdba3
+
+pkgname = soundclip-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..451ab8809352
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+soundclip/
+soundclip-git/
+*.pkg* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e7d80add66c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+_pkg=soundclip
+_ver=0.1
+pkgname="${_pkg}-git"
+pkgver="${_ver}.3841f84"
+pkgrel=1
+pkgdesc='Theatre Sound Cue Management'
+arch=('i686' 'x86_64')
+url='https://github.com/soundclip/soundclip'
+license=('GPL')
+depends=('java-runtime>=8' 'gstreamer')
+makedepends=('maven>=3' 'java-environment-jdk>=8')
+source=("${pkgname}::git+${url}.git"
+ 'soundclip-launcher'
+ 'soundclip.desktop')
+sha256sums=('SKIP'
+ '26e71d5998b5341a670d9eea0be21c14a90546a9052e3a606d52bcafbe210dfe'
+ 'ed8a89f67ee4b0c0fe831da35d2fd0d3731f951c723068949705aed6d9ffdba3')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "$_ver.%s" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ mvn package
+}
+
+package() {
+ install -Dm644 "$srcdir/$pkgname/Soundclip/target/Soundclip-$_ver-SNAPSHOT-jar-with-dependencies.jar" "$pkgdir/usr/share/java/soundclip/soundclip.jar"
+ install -Dm755 soundclip-launcher "$pkgdir/usr/bin/soundclip"
+ install -Dm644 soundclip.desktop "$pkgdir/usr/share/applications/soundclip.desktop"
+ install -Dm644 "$srcdir/$pkgname/Soundclip/src/main/resources/img/icon/icon_512x512.png" "$pkgdir/usr/share/pixmaps/soundclip.png"
+} \ No newline at end of file
diff --git a/soundclip-launcher b/soundclip-launcher
new file mode 100644
index 000000000000..fbc39a0bfb3b
--- /dev/null
+++ b/soundclip-launcher
@@ -0,0 +1,2 @@
+#!/bin/bash
+exec /usr/bin/java -jar /usr/share/java/soundclip/soundclip.jar "$@" \ No newline at end of file
diff --git a/soundclip.desktop b/soundclip.desktop
new file mode 100644
index 000000000000..34cbb559e90e
--- /dev/null
+++ b/soundclip.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=SoundClip
+Comment=Theatre Sound Cue Management
+Exec=soundclip
+Icon=soundclip
+StartupNotify=true
+StartupWMClass=soundclip.Soundclip
+Terminal=false
+Categories=Media;Java; \ No newline at end of file