summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE6
-rw-r--r--PKGBUILD54
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8154eba560ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = soundfont-toh
+ pkgdesc = Don Allen's Timbres of Heaven soundfont
+ pkgver = 3.2
+ pkgrel = 1
+ url = http://midkar.com/soundfonts/
+ arch = any
+ license = custom
+ source = LICENSE
+ md5sums = 3fd3aa3e20d7ea437293b8e13723aae1
+
+pkgname = soundfont-toh
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..39effa3dff6e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,6 @@
+
+ 'UNLIMITED' Free Use
+
+ "Timbres Of Heaven" is created and developed by Don Allen, and may not be distributed on
+ any site without the express written permission of Don Allen, or Midkar.com.
+ © 2013, 2015; All Rights Reserved.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f66aed23c19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+
+# Due to the license's distribution condition,
+# you need to download the archive below and put it in PKGBUILD directory.
+# http://www.mediafire.com/download/klclifq2g91o2tq/Timbres+Of+Heaven+GM_GS_XG_SFX+V+3.2+Final.7z
+# For latest versions, see <http://midkar.com/soundfonts/> and inform the AUR package maintainer.
+
+pkgname=soundfont-toh
+pkgver=('3.2' 'Final')
+pkgrel=1
+pkgdesc="Don Allen's Timbres of Heaven soundfont"
+arch=('any')
+url="http://midkar.com/soundfonts/"
+license=('custom')
+source=('LICENSE')
+md5sums=('3fd3aa3e20d7ea437293b8e13723aae1')
+
+_local_src=("Timbres Of Heaven GM_GS_XG_SFX V ${pkgver[0]} ${pkgver[1]}.7z")
+_local_md5sums=('92bca630ea3939c1e19646e09299dd1d')
+
+prepare() {
+ cd "${srcdir%/*}/"
+ msg "$(gettext "Validating source files with %s...")" "md5sums"
+ local md5_cnt=0 file errors=0
+ for file in "${_local_src[@]}"; do
+ if [[ -s "$file" ]]; then
+ printf ' %s ... ' "$file" >&2
+ if [[ "${_local_md5sums["$md5_cnt"]}" == "`md5sum "$file" | awk '{ print $1 }'`" ]]; then
+ printf '%s\n' "$(gettext "Passed")" >&2
+ else
+ printf '%s\n' "$(gettext "FAILED")" >&2 || errors=1
+ fi
+ md5_cnt=$[md5_cnt+1]
+ else
+ error "$(gettext "Unable to find source file %s.")" "$file"
+ return 1
+ fi
+ done
+ if (( errors )); then
+ error "$(gettext "One or more files did not pass the validity check!")"
+ return 1
+ fi
+
+ # Extracting package
+ msg "$(gettext "Extracting sources...")"
+ bsdtar -xf "$_local_src" -C "$srcdir/"
+}
+
+package() {
+ install -Dm0644 "$srcdir/${_local_src%.*}.sf2" "$pkgdir/usr/share/soundfonts/${_local_src%.*}.sf2"
+ install -Dm0644 "$srcdir/${_local_src%.*}.txt" "$pkgdir/usr/share/doc/${pkgname}/${_local_src%.*}.txt"
+ install -Dm0644 "$srcdir/Timbres_of_Heaven.mlb" "$pkgdir/usr/share/doc/${pkgname}/Timbres_of_Heaven.mlb"
+ install -Dm0644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}