summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD44
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..097c0dd530f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = soundscrape-git
+ pkgdesc = SoundCloud (and Bandcamp and Mixcloud) downloader in Python.
+ pkgver = r237.efc63b9
+ pkgrel = 1
+ url = https://github.com/Miserlou/SoundScrape
+ arch = any
+ license = Apache
+ checkdepends = python-nose
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-args
+ depends = python-clint
+ depends = python-demjson
+ depends = python-fudge
+ depends = python-requests
+ depends = python-simplejson
+ depends = python-soundcloud
+ depends = python-wheel
+ depends = python-mutagen
+ provides = soundscrape
+ source = git+https://github.com/Miserlou/SoundScrape.git
+ sha512sums = SKIP
+
+pkgname = soundscrape-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..661733e30bbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Andrea Pascal <andrea@anodium.net>
+
+pkgname=soundscrape-git
+pkgver=r237.efc63b9
+pkgrel=1
+pkgdesc='SoundCloud (and Bandcamp and Mixcloud) downloader in Python.'
+arch=('any')
+url='https://github.com/Miserlou/SoundScrape'
+license=('Apache')
+
+provides=('soundscrape')
+depends=(
+ 'python'
+ 'python-args'
+ 'python-clint'
+ 'python-demjson'
+ 'python-fudge'
+ 'python-requests'
+ 'python-simplejson'
+ 'python-soundcloud'
+ 'python-wheel'
+ 'python-mutagen'
+)
+makedepends=('git' 'python-setuptools')
+checkdepends=('python-nose')
+
+source=('git+https://github.com/Miserlou/SoundScrape.git')
+sha512sums=('SKIP')
+
+
+build() {
+ cd $srcdir/SoundScrape
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/SoundScrape
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+check() {
+ cd $srcdir/SoundScrape
+ nosetests
+}