summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
-rw-r--r--soundsync.sh16
3 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6363589ad7be..ccbee1f38606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = soundsync-bin
pkgdesc = Virtual cables between any audio source and any speaker in your home
pkgver = 0.4.16
- pkgrel = 6
+ pkgrel = 7
url = https://soundsync.app/
arch = x86_64
license = custom:BSL1.1
- depends = bash
depends = electron15
depends = libpulse
depends = python
provides = soundsync=0.4.16
conflicts = soundsync
source = soundsync-0.4.16.pacman::https://github.com/geekuillaume/soundsync/releases/download/v0.4.16/soundsync-x64-0.4.16.pacman
- source = LICENSE::https://raw.githubusercontent.com/geekuillaume/soundsync/v0.4.16/LICENSE
+ source = LICENSE-0.4.16::https://raw.githubusercontent.com/geekuillaume/soundsync/v0.4.16/LICENSE
source = soundsync.service
source = soundsync.sh
sha256sums = 12bd6190537d80a29fa89fa2fa37da310593d5e6c54a7fe9f16c5f1509d4b94c
sha256sums = 0c659fd7972a1a233b161380cfb177149d6d75b3c4f97c8cf8bbd8eb91b026d0
sha256sums = b0b07f20aa91c04c6aa05590ebd4d4697b2939283bcb122810759a2ed961a005
- sha256sums = b3245324709a5bd6bca234e1e658218fc27fa2d0a21a5d0cef8b39cb1a7c6a4a
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
pkgname = soundsync-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2b6b6aec7064..c9c70bc93b18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,35 @@
pkgname=soundsync-bin
_pkgname=Soundsync
pkgver=0.4.16
-pkgrel=6
+_electronversion=15
+pkgrel=7
pkgdesc="Virtual cables between any audio source and any speaker in your home"
arch=('x86_64')
url="https://soundsync.app/"
-_githuburl="https://github.com/geekuillaume/soundsync"
+_ghurl="https://github.com/geekuillaume/soundsync"
license=('custom:BSL1.1')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'bash'
- 'electron15'
+ "electron${_electronversion}"
'libpulse'
'python'
)
source=(
- "${pkgname%-bin}-${pkgver}.pacman::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-x64-${pkgver}.pacman"
- "LICENSE::https://raw.githubusercontent.com/geekuillaume/soundsync/v${pkgver}/LICENSE"
+ "${pkgname%-bin}-${pkgver}.pacman::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-x64-${pkgver}.pacman"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/geekuillaume/soundsync/v${pkgver}/LICENSE"
"${pkgname%-bin}.service"
"${pkgname%-bin}.sh"
)
sha256sums=('12bd6190537d80a29fa89fa2fa37da310593d5e6c54a7fe9f16c5f1509d4b94c'
'0c659fd7972a1a233b161380cfb177149d6d75b3c4f97c8cf8bbd8eb91b026d0'
'b0b07f20aa91c04c6aa05590ebd4d4697b2939283bcb122810759a2ed961a005'
- 'b3245324709a5bd6bca234e1e658218fc27fa2d0a21a5d0cef8b39cb1a7c6a4a')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
sed "s|/opt/${_pkgname}/${pkgname%-bin} %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
@@ -37,7 +41,7 @@ package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm755 -d "${pkgdir}/usr/lib/${pkgname%-bin}"
cp -r "${srcdir}/opt/${_pkgname}/resources/"{app,res,webui} "${pkgdir}/usr/lib/${pkgname%-bin}"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 "${srcdir}/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/soundsync.sh b/soundsync.sh
index f5c6d54d6f07..2ec4412e5c4f 100644
--- a/soundsync.sh
+++ b/soundsync.sh
@@ -1,10 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron15
-APPDIR="/usr/lib/soundsync"
-export PATH="${APPDIR}:${PATH}"
-_ASAR="${APPDIR}/app"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file