summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Silence-errors-due-to-which-failing-to-find-swiftenv.patch26
-rw-r--r--PKGBUILD11
3 files changed, 8 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74639ad2ede9..a77a2344c7e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = sourcekitten
- pkgdesc = An adorable little framework and command line tool for interacting with SourceKit..
- pkgver = 0.22.0
+ pkgdesc = An adorable little framework and command line tool for interacting with SourceKit.
+ pkgver = 0.26.0
pkgrel = 1
url = https://github.com/jpsim/SourceKitten
arch = any
license = MIT
makedepends = swift-language
depends = swift-language
- source = https://github.com/jpsim/SourceKitten/archive/0.22.0.tar.gz
- source = 0001-Silence-errors-due-to-which-failing-to-find-swiftenv.patch
- sha256sums = 61f92e16c7dacd8e1389e42c5e9ccc350c73e962b7d73b7ef92608d222a744c4
- sha256sums = SKIP
+ source = https://github.com/jpsim/SourceKitten/archive/0.26.0.tar.gz
+ sha256sums = 4c8ab67f15654a11da3739b966f5a0b379cf7a7626095238ad921d958c559c86
pkgname = sourcekitten
diff --git a/0001-Silence-errors-due-to-which-failing-to-find-swiftenv.patch b/0001-Silence-errors-due-to-which-failing-to-find-swiftenv.patch
deleted file mode 100644
index b3aa84089006..000000000000
--- a/0001-Silence-errors-due-to-which-failing-to-find-swiftenv.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 8ea65d0a2c22468276d202d746877fa67083cf12 Mon Sep 17 00:00:00 2001
-From: Ryan Gonzalez <rymg19@gmail.com>
-Date: Sat, 2 Mar 2019 13:21:46 -0600
-Subject: [PATCH] Silence errors due to which failing to find swiftenv
-
----
- Source/SourceKittenFramework/library_wrapper.swift | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/Source/SourceKittenFramework/library_wrapper.swift b/Source/SourceKittenFramework/library_wrapper.swift
-index 0651afe..6a0a440 100644
---- a/Source/SourceKittenFramework/library_wrapper.swift
-+++ b/Source/SourceKittenFramework/library_wrapper.swift
-@@ -79,6 +79,9 @@ private func runCommand(_ path: String, _ args: String...) -> String? {
-
- let pipe = Pipe()
- process.standardOutput = pipe
-+ // FileHandle.nullDevice does not work here, as it consists of an invalid file descriptor,
-+ // causing process.launch() to abort with an EBADF.
-+ process.standardError = FileHandle(forWritingAtPath: "/dev/null")!
- process.launch()
-
- let data = pipe.fileHandleForReading.readDataToEndOfFile()
---
-2.20.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 748e4c2b281a..73bedf97af3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,19 @@
# Maintainer: Ryan Gonzalez <rymg19 at gmail dot com>
pkgname=sourcekitten
-pkgver=0.22.0
+pkgver=0.26.0
pkgrel=1
-pkgdesc='An adorable little framework and command line tool for interacting with SourceKit..'
+pkgdesc='An adorable little framework and command line tool for interacting with SourceKit.'
arch=('any')
url='https://github.com/jpsim/SourceKitten'
license=('MIT')
depends=('swift-language')
makedepends=('swift-language')
-source=("https://github.com/jpsim/SourceKitten/archive/$pkgver.tar.gz"
- 0001-Silence-errors-due-to-which-failing-to-find-swiftenv.patch)
-sha256sums=('61f92e16c7dacd8e1389e42c5e9ccc350c73e962b7d73b7ef92608d222a744c4'
- SKIP)
+source=("https://github.com/jpsim/SourceKitten/archive/$pkgver.tar.gz")
+sha256sums=('4c8ab67f15654a11da3739b966f5a0b379cf7a7626095238ad921d958c559c86')
prepare() {
cd "SourceKitten-$pkgver"
- patch -p1 -i "${srcdir}/0001-Silence-errors-due-to-which-failing-to-find-swiftenv.patch"
}
package() {