summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eeca756455a8..e8511353eb3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Dec 10 21:35:35 UTC 2015
pkgbase = spacevecalg-git
pkgdesc = Implementation of spatial vector algebra with the Eigen 3 linear algebra library.
- pkgver = 20150701
+ pkgver = r97.9d97669
pkgrel = 1
url = https://github.com/jorisv/SpaceVecAlg
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 876337277ab5..f5abd266f063 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,7 @@
pkgname=spacevecalg-git
_name=spacevecalg
-pkgver=20150701
-pkgver() {
- date +%Y%m%d
-}
+pkgver=r97.9d97669
pkgrel=1
pkgdesc="Implementation of spatial vector algebra with the Eigen 3 linear algebra library."
arch=('i686' 'x86_64')
@@ -17,6 +14,14 @@ provides=('spacevecalg')
source=("${_name}::git+https://github.com/jorisv/SpaceVecAlg")
md5sums=('SKIP')
+pkgver() {
+ cd "${srcdir}/${_name}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
build()
{
cd "${srcdir}/${_name}"