summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--spamprobe-lrucache.patch11
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 706b976446e2..245f55f09bd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spamprobe
pkgdesc = Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails
pkgver = 1.4d
- pkgrel = 7
+ pkgrel = 8
url = http://spamprobe.sourceforge.net/
arch = i686
arch = x86_64
@@ -16,12 +16,13 @@ pkgbase = spamprobe
source = spamprobe-png.patch
source = spamprobe-template.patch
source = spamprobe-giflib.patch
+ source = spamprobe-lrucache.patch
sha256sums = 217ce47dcc6f58d8201fbb0a5e2dc38b5b06349fadb1378fb3647ad8a3f44d68
sha256sums = 74c047a55a6e9a553bee29b5f46725b43821fa29630e2ca2ab348ea0852d070d
sha256sums = 2f1a60295b2832a8c174efb2efa3d54a9268235795560b35a63f2b31bfd59019
sha256sums = 3e99cf08dab2a461e1afada44d809dee2407ec990b3e76175fc026cda2830ded
sha256sums = 220523fb2e7e5c94d1f01cf54052e7bf3124bf342779953abe1355789129e621
sha256sums = af1a610bee4f4d4ad68267b88278d837ecde271e371342497f1b048e528d7d36
+ sha256sums = 9814777be778cec4987efc17963296a1429bdd15c7a392e54111af137d8ebc72
pkgname = spamprobe
-
diff --git a/PKGBUILD b/PKGBUILD
index 7c94523bacb5..36a9f102685b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=spamprobe
pkgver=1.4d
-pkgrel=7
+pkgrel=8
pkgdesc="Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails"
arch=(i686 x86_64)
url="http://spamprobe.sourceforge.net/"
@@ -11,13 +11,15 @@ license=('custom:QPL')
depends=(db giflib libjpeg libpng)
source=(http://downloads.sourceforge.net/spamprobe/$pkgname-$pkgver.tar.gz
spamprobe-db5.patch spamprobe-gcc43.patch spamprobe-png.patch
- spamprobe-template.patch spamprobe-giflib.patch)
+ spamprobe-template.patch spamprobe-giflib.patch
+ spamprobe-lrucache.patch)
sha256sums=('217ce47dcc6f58d8201fbb0a5e2dc38b5b06349fadb1378fb3647ad8a3f44d68'
'74c047a55a6e9a553bee29b5f46725b43821fa29630e2ca2ab348ea0852d070d'
'2f1a60295b2832a8c174efb2efa3d54a9268235795560b35a63f2b31bfd59019'
'3e99cf08dab2a461e1afada44d809dee2407ec990b3e76175fc026cda2830ded'
'220523fb2e7e5c94d1f01cf54052e7bf3124bf342779953abe1355789129e621'
- 'af1a610bee4f4d4ad68267b88278d837ecde271e371342497f1b048e528d7d36')
+ 'af1a610bee4f4d4ad68267b88278d837ecde271e371342497f1b048e528d7d36'
+ '9814777be778cec4987efc17963296a1429bdd15c7a392e54111af137d8ebc72')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -26,6 +28,7 @@ build() {
patch -p0 -i $srcdir/spamprobe-db5.patch
patch -p0 -i $srcdir/spamprobe-template.patch
patch -p0 -i $srcdir/spamprobe-giflib.patch
+ patch -p0 -i $srcdir/spamprobe-lrucache.patch
./configure --prefix=/usr --mandir=/usr/share/man
make
}
diff --git a/spamprobe-lrucache.patch b/spamprobe-lrucache.patch
new file mode 100644
index 000000000000..2b489bd9d609
--- /dev/null
+++ b/spamprobe-lrucache.patch
@@ -0,0 +1,11 @@
+--- src/includes/LRUCache.h.orig 2018-08-14 08:00:27 UTC
++++ src/includes/LRUCache.h
+@@ -60,7 +60,7 @@ template<class KeyType, class ValueType> class LRUCach
+ {
+ public:
+ bool operator()(const NodeType *a,
+- const NodeType *b)
++ const NodeType *b) const
+ {
+ return a->key < b->key;
+ }