summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0744ce8a01ae..ebca94709a66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = sparta
pkgdesc = Is a python GUI application which simplifies network infrastructure penetration testing by aiding the penetration tester in the scanning and enumeration phase.
- pkgver = 1.0.2beta
+ pkgver = 1.0.1
pkgrel = 1
url = http://sparta.secforce.com/
arch = any
license = GPL2
- makedepends = git
depends = python2
depends = python2-pyqt4
depends = python2-elixir
depends = python2-lxml
- source = https://github.com/SECFORCE/sparta/archive/master.zip
- sha256sums = d6318d399bb41f4ac3f2c8b1ab9309ba4cbcc98a7be2448cccffb58fe47acd1c
+ conflicts = sparta-git
+ source = https://github.com/SECFORCE/sparta/archive/v1.0.1.tar.gz
+ sha256sums = 14aba154a94f2f31929087849c0dde44cdb59c337a8ecf2b0cecbae71690738f
pkgname = sparta
diff --git a/PKGBUILD b/PKGBUILD
index cc9008bf387a..c99f37c35fa9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# Contributor: Cyberpunk <apocalipsisfull-2011@outlook.com>
-# Maintainer: Cyberpunk <apocalipsisfull-2011@outlook.com>
+# Contributor: Cyberpunk <aur_linuxero@outlook.com>
+# Maintainer: Cyberpunk <aur_linuxero@outlook.com>
pkgname=sparta
-_pkgname=master
-pkgver=1.0.2beta
+pkgver=1.0.1
pkgrel=1
pkgdesc="Is a python GUI application which simplifies network infrastructure penetration testing by aiding the penetration tester in the scanning and enumeration phase."
arch=('any')
@@ -11,15 +10,15 @@ url="http://sparta.secforce.com/"
license=('GPL2')
depends=('python2' 'python2-pyqt4' 'python2-elixir' 'python2-lxml')
makedeps=('nmap' 'hydra' 'cutycapt-svn' 'nikto')
-makedepends=('git')
provide=('sparta')
-source=('https://github.com/SECFORCE/sparta/archive/master.zip')
+conflicts=('sparta-git')
+source=("https://github.com/SECFORCE/sparta/archive/v${pkgver}.tar.gz")
package() {
msg2 "Installing sparta..."
install -dm755 "${pkgdir}/usr/bin/"
install -dm755 "${pkgdir}/usr/share/${pkgname}"
- cd "${srcdir}/${pkgname}-${_pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
cp -aRp --copy-contents * "${pkgdir}/usr/share/${pkgname}"
cat > $pkgdir/usr/bin/sparta << "EOF"
@@ -28,4 +27,4 @@ cd /usr/share/sparta/ && python2 sparta.py "$@"
EOF
chmod 755 "$pkgdir/usr/bin/sparta"
}
-sha256sums=('d6318d399bb41f4ac3f2c8b1ab9309ba4cbcc98a7be2448cccffb58fe47acd1c')
+sha256sums=('14aba154a94f2f31929087849c0dde44cdb59c337a8ecf2b0cecbae71690738f')